aboutsummaryrefslogtreecommitdiff
path: root/textproc/multimarkdown
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2013-11-14 23:31:25 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2013-11-14 23:31:25 +0000
commit173508a4568c154d785bc54836630ccd368e0614 (patch)
tree82db7ff47a32f45475e2989ed5382320b1cdbb88 /textproc/multimarkdown
parentb6737862c1c146cab2f83001bfb44ab69f862157 (diff)
downloadports-173508a4568c154d785bc54836630ccd368e0614.tar.gz
ports-173508a4568c154d785bc54836630ccd368e0614.zip
Use bsd.git-clone.mk.
Notes
Notes: svn path=/head/; revision=333808
Diffstat (limited to 'textproc/multimarkdown')
-rw-r--r--textproc/multimarkdown/Makefile20
1 files changed, 5 insertions, 15 deletions
diff --git a/textproc/multimarkdown/Makefile b/textproc/multimarkdown/Makefile
index 26547abfc653..a17b437d3544 100644
--- a/textproc/multimarkdown/Makefile
+++ b/textproc/multimarkdown/Makefile
@@ -12,9 +12,9 @@ COMMENT= Extended Markdown processor with more features, written in C
LICENSE= MIT
-FETCH_DEPENDS= git:${PORTSDIR}/devel/git
-
-WRKSRC= ${WRKDIR}/MultiMarkdown-4
+GITHUB_CREATOR= fletcher
+GIT_PROJECT_NAME= MultiMarkdown-4
+GIT_SUBMODULES= yes
ALL_TARGET= ${PORTNAME}
@@ -31,18 +31,6 @@ OPTIONS_SUB= yes
CONFLICTS_INSTALL= mtools-*
.endif
-do-fetch:
- @if [ ! -e ${WRKSRC}/greg/Makefile ]; then \
- ${MKDIR} ${WRKDIR}; \
- cd ${WRKDIR} && git clone https://github.com/fletcher/MultiMarkdown-4.git; \
- cd ${WRKSRC} && git checkout ${PORTVERSION}; \
- cd ${WRKSRC} && git submodule init; \
- cd ${WRKSRC} && git submodule update; \
- fi
-
-do-extract:
- @${DO_NADA} #normally do-extract starts with an rm -rf ${WRKSRC}
-
post-patch:
@${REINPLACE_CMD} -E "s/^(CFLAGS).+=/\1 \+=/" ${WRKSRC}/Makefile ${WRKSRC}/greg/Makefile
@${REINPLACE_CMD} -E "s,^(xslt_path)=.*,\1=${DATADIR},; s,(xslt_path)/../,\1/," \
@@ -70,4 +58,6 @@ do-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}/cheat-sheet
cd ${WRKSRC} && ${FIND} cheat-sheet -not -path '*/.git*' | \
${CPIO} -pdmu --quiet ${STAGEDIR}${DOCSDIR}
+
+.include "${.CURDIR}/bsd.git-clone.mk"
.include <bsd.port.mk>