aboutsummaryrefslogtreecommitdiff
path: root/textproc/multimarkdown
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2013-10-31 00:37:47 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2013-10-31 00:37:47 +0000
commitd0fc26ef69c762499cff836a03db510d19d0de5d (patch)
tree1858f26a591277e15dff66edc8f823783bc28c60 /textproc/multimarkdown
parent1752bb5a6e253b2040e8fc493b85d7980962c42c (diff)
downloadports-d0fc26ef69c762499cff836a03db510d19d0de5d.tar.gz
ports-d0fc26ef69c762499cff836a03db510d19d0de5d.zip
Run the git commands in fetch instead of extract. The package cluster
disables dialling out during extract. Thanks to: William Grzybowski <william88@gmail.com>
Notes
Notes: svn path=/head/; revision=332190
Diffstat (limited to 'textproc/multimarkdown')
-rw-r--r--textproc/multimarkdown/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/textproc/multimarkdown/Makefile b/textproc/multimarkdown/Makefile
index 802fa91062d2..d41d7e8dd0ab 100644
--- a/textproc/multimarkdown/Makefile
+++ b/textproc/multimarkdown/Makefile
@@ -12,7 +12,7 @@ COMMENT= Extended Markdown processor with more features, written in C
LICENSE= MIT
-EXTRACT_DEPENDS= git:${PORTSDIR}/devel/git
+FETCH_DEPENDS= git:${PORTSDIR}/devel/git
WRKSRC= ${WRKDIR}/MultiMarkdown-4
@@ -31,13 +31,16 @@ OPTIONS_SUB= yes
CONFLICTS_INSTALL= mtools-*
.endif
-do-extract:
+do-fetch:
${MKDIR} ${WRKDIR}
cd ${WRKDIR} && git clone https://github.com/fletcher/MultiMarkdown-4.git
cd ${WRKSRC} && git checkout ${PORTVERSION}
cd ${WRKSRC} && git submodule init
cd ${WRKSRC} && git submodule update
+do-extract:
+ @${DO_NADA} #normally do-extract starts with an rm -rf ${WRKSRC}
+
post-patch:
@${REINPLACE_CMD} -E "s/^(CFLAGS).+=/\1 \+=/" ${WRKSRC}/Makefile ${WRKSRC}/greg/Makefile
@${REINPLACE_CMD} -E "s,^(xslt_path)=.*,\1=${DATADIR},; s,(xslt_path)/../,\1/," \