aboutsummaryrefslogtreecommitdiff
path: root/textproc/multimarkdown
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2013-08-11 12:36:12 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2013-08-11 12:36:12 +0000
commitfe8cb68f9fb77751b557fbaea8a2e992a4ca4008 (patch)
tree61b74da56ab29950ad48fa18f9a3e424a112ab02 /textproc/multimarkdown
parentde7fed42b48a417b29b8b58c938da2aa605fc873 (diff)
downloadports-fe8cb68f9fb77751b557fbaea8a2e992a4ca4008.tar.gz
ports-fe8cb68f9fb77751b557fbaea8a2e992a4ca4008.zip
Use MDOCS instead of NOPORTDOCS.
Correct permissions on scripts. PORTREVISION bump for this.
Notes
Notes: svn path=/head/; revision=324584
Diffstat (limited to 'textproc/multimarkdown')
-rw-r--r--textproc/multimarkdown/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/textproc/multimarkdown/Makefile b/textproc/multimarkdown/Makefile
index ac280cd5a00b..a12cff89d9c6 100644
--- a/textproc/multimarkdown/Makefile
+++ b/textproc/multimarkdown/Makefile
@@ -1,12 +1,11 @@
-# New ports collection makefile for: multimarkdown
-# Date created: 27 October 2011
-# Whom: Adam Weinberger <adamw@FreeBSD.org>
+# Created by: Adam Weinberger <adamw@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= multimarkdown
PORTVERSION= 3.7.1
+PORTREVISION= 1
DISTNAME= peg-${PORTNAME}-${PORTVERSION}
CATEGORIES= textproc
MASTER_SITES= http://github.com/fletcher/peg-${PORTNAME}/archive/${PORTVERSION}.tar.gz?dummy=/
@@ -27,16 +26,20 @@ MAKE_JOBS_UNSAFE= yes
PLIST_FILES= bin/multimarkdown bin/mmd bin/mmd2all bin/mmd2odf bin/mmd2opml bin/mmd2pdf bin/mmd2tex
PORTDOCS= LICENSE README.markdown
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -E "/CFLAGS/s/-arch [[:alnum:]]+//; /CFLAGS/s/\?=/\+=/" \
${WRKSRC}/Makefile
do-install:
- @${INSTALL} -m 755 ${WRKSRC}/multimarkdown ${PREFIX}/bin
- @${INSTALL} -m 755 ${WRKSRC}/scripts/* ${PREFIX}/bin
-.if !defined(NOPORTDOCS)
+ ${INSTALL_SCRIPT} ${WRKSRC}/multimarkdown ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/scripts/* ${PREFIX}/bin
+
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- @(cd ${WRKSRC}; ${INSTALL} -m 644 LICENSE README.markdown ${DOCSDIR})
+ ${INSTALL_DATA} ${WRKSRC}/LICENSE ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.markdown ${DOCSDIR}
.endif
.include <bsd.port.mk>