aboutsummaryrefslogtreecommitdiff
path: root/textproc/mysqlviz/Makefile
diff options
context:
space:
mode:
authorTAKATSU Tomonari <tota@FreeBSD.org>2013-05-06 14:10:45 +0000
committerTAKATSU Tomonari <tota@FreeBSD.org>2013-05-06 14:10:45 +0000
commit59a300d3c1da566e6963ad2f52f374a0be8d32f6 (patch)
tree3de4d333ee3fe1b5de3cd2be8cc0705cf65c6165 /textproc/mysqlviz/Makefile
parentce85acab769712d5abf778e61b11c25416af00f2 (diff)
Notes
Diffstat (limited to 'textproc/mysqlviz/Makefile')
-rw-r--r--textproc/mysqlviz/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/textproc/mysqlviz/Makefile b/textproc/mysqlviz/Makefile
new file mode 100644
index 000000000000..6d53abf579d3
--- /dev/null
+++ b/textproc/mysqlviz/Makefile
@@ -0,0 +1,37 @@
+# Created by: TAKATSU Tomonari <tota@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mysqlviz
+PORTVERSION= 0.3
+CATEGORIES= textproc
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= MySQL and SQLite Database Visualisation Tool
+
+NO_BUILD= yes
+USE_BZIP2= yes
+USE_PHP= yes
+WANT_PHP_CLI= yes
+
+PLIST_FILES= bin/${PORTNAME}
+
+PORTEXAMPLES= eg.png eg.sql sqlite-eg.sql
+
+OPTIONS_DEFINE= EXAMPLES
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's|/usr/bin/php|${LOCALBASE}/bin/php|' \
+ ${WRKSRC}/${PORTNAME}
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTEXAMPLES} ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>