aboutsummaryrefslogtreecommitdiff
path: root/textproc/nl-mythes
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-19 05:31:29 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-19 06:00:49 +0000
commit72664fc2b4d33ca3ae39c8e7ab6f8fa85c08bd63 (patch)
tree5a38291fea0ecf3734c8329b934dc334c8a9feb8 /textproc/nl-mythes
parent915dbfaa562e20c8402d3873f8bfbf07899f9f8a (diff)
downloadports-72664fc2b4d33ca3ae39c8e7ab6f8fa85c08bd63.tar.gz
ports-72664fc2b4d33ca3ae39c8e7ab6f8fa85c08bd63.zip
Diffstat (limited to 'textproc/nl-mythes')
-rw-r--r--textproc/nl-mythes/Makefile8
-rw-r--r--textproc/nl-mythes/Makefile 37
2 files changed, 41 insertions, 4 deletions
diff --git a/textproc/nl-mythes/Makefile b/textproc/nl-mythes/Makefile
index 50f463d5ce2e..50ade4cfb96c 100644
--- a/textproc/nl-mythes/Makefile
+++ b/textproc/nl-mythes/Makefile
@@ -16,13 +16,13 @@ NO_ARCH= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
-PLIST_FILES= %%DATADIR%%/th_nl_NL_v2.dat \
- %%DATADIR%%/th_nl_NL_v2.idx
+PLIST_FILES= ${DATADIR}/th_nl_NL_v2.dat \
+ ${DATADIR}/th_nl_NL_v2.idx
NLALIASES= nl_AW nl_BE
.for ALIAS in ${NLALIASES}
-PLIST_FILES+= %%DATADIR%%/th_${ALIAS}_v2.dat \
- %%DATADIR%%/th_${ALIAS}_v2.idx
+PLIST_FILES+= ${DATADIR}/th_${ALIAS}_v2.dat \
+ ${DATADIR}/th_${ALIAS}_v2.idx
.endfor
do-install:
diff --git a/textproc/nl-mythes/Makefile b/textproc/nl-mythes/Makefile
new file mode 100644
index 000000000000..50f463d5ce2e
--- /dev/null
+++ b/textproc/nl-mythes/Makefile
@@ -0,0 +1,37 @@
+PORTNAME= mythes
+PORTVERSION= 2015.12.10
+CATEGORIES= textproc
+MASTER_SITES= LOCAL/sunpoet/${PORTNAME}/
+PKGNAMEPREFIX= nl-
+DISTNAME= thes_nl-${PORTVERSION:C/\.//g}
+EXTRACT_SUFX= .oxt
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Dutch thesaurus
+
+LICENSE= BSD3CLAUSE
+
+NO_ARCH= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= %%DATADIR%%/th_nl_NL_v2.dat \
+ %%DATADIR%%/th_nl_NL_v2.idx
+
+NLALIASES= nl_AW nl_BE
+.for ALIAS in ${NLALIASES}
+PLIST_FILES+= %%DATADIR%%/th_${ALIAS}_v2.dat \
+ %%DATADIR%%/th_${ALIAS}_v2.idx
+.endfor
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/th_nl_v2.dat ${STAGEDIR}${DATADIR}/th_nl_NL_v2.dat
+ ${INSTALL_DATA} ${WRKSRC}/th_nl_v2.dat ${STAGEDIR}${DATADIR}/th_nl_NL_v2.idx
+.for ALIAS in ${NLALIASES}
+ ${LN} -s th_nl_NL_v2.dat ${STAGEDIR}${DATADIR}/th_${ALIAS}_v2.dat
+ ${LN} -s th_nl_NL_v2.idx ${STAGEDIR}${DATADIR}/th_${ALIAS}_v2.idx
+.endfor
+
+.include <bsd.port.mk>