aboutsummaryrefslogtreecommitdiff
path: root/textproc/ocaml-text
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-03-26 20:41:58 +0000
committerJohn Marino <marino@FreeBSD.org>2014-03-26 20:41:58 +0000
commitbbbd4c80dd298c03415242fc508261539f70e4f8 (patch)
tree86818a8e4ec5ea21664fd2e2b71721e8697f4286 /textproc/ocaml-text
parentddc50965ceb5f8cbcc535caaeb1cc0f7d4f82e84 (diff)
downloadports-bbbd4c80dd298c03415242fc508261539f70e4f8.tar.gz
ports-bbbd4c80dd298c03415242fc508261539f70e4f8.zip
textproc/ocaml-text: Update version 0.5 -> 0.6 and stage
Since the maintainer also maintains the pkgsrc version of ocaml-text, I used their methods for implementing stage. I am perplexed about the change in the pkg-plist because no documents were generated and there were no documents on pkgsrc plist either. As with other recent ocaml changes, ldconf changes were inhibited. ldconf probably needs a new global policy (e.g. apply in a post-install script) PR: ports/176060 Submitted by: maintainer (Jaap Boender) Stage support: Taken from pkgsrc
Notes
Notes: svn path=/head/; revision=349291
Diffstat (limited to 'textproc/ocaml-text')
-rw-r--r--textproc/ocaml-text/Makefile36
-rw-r--r--textproc/ocaml-text/distinfo4
-rw-r--r--textproc/ocaml-text/pkg-plist60
3 files changed, 62 insertions, 38 deletions
diff --git a/textproc/ocaml-text/Makefile b/textproc/ocaml-text/Makefile
index 70ae56d6b8d9..eddeb71dda46 100644
--- a/textproc/ocaml-text/Makefile
+++ b/textproc/ocaml-text/Makefile
@@ -2,45 +2,45 @@
# $FreeBSD$
PORTNAME= text
-PORTVERSION= 0.5
+PORTVERSION= 0.6
CATEGORIES= textproc
-MASTER_SITES= http://forge.ocamlcore.org/frs/download.php/641/
+MASTER_SITES= http://forge.ocamlcore.org/frs/download.php/937/
PKGNAMEPREFIX= ocaml-
DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
MAINTAINER= jaapb@kerguelen.org
COMMENT= OCaml library for dealing with text
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --docdir ${DOCSDIR} --prefix ${PREFIX} --mandir ${PREFIX}/man
USES= gmake
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix ${PREFIX} \
+ --destdir ${STAGEDIR}
USE_OCAML= yes
USE_OCAML_FINDLIB= yes
-USE_OCAML_LDCONFIG= yes
-USE_OCAMLFIND_PLIST= yes
SA_DIR= ${LOCALBASE}/${OCAML_SITELIBDIR}
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
-OPTIONS_DEFINE= PCRE
+OPTIONS_DEFINE= PCRE
OPTIONS_DEFAULT= PCRE
PCRE_CONFIGURE_ENABLE= pcre
PCRE_BUILD_DEPENDS= ${SA_DIR}/pcre/pcre.a:${PORTSDIR}/devel/ocaml-pcre
PCRE_RUN_DEPENDS= ${SA_DIR}/pcre/pcre.a:${PORTSDIR}/devel/ocaml-pcre
-NO_STAGE= yes
-post-extract:
-# For non-standard prefixes
-.if !exists(${OCAMLFIND_DESTDIR})
- ${MKDIR} ${OCAMLFIND_DESTDIR}
-.endif
-.if !exists(${OCAMLFIND_LDCONF})
- ${TOUCH} ${OCAMLFIND_LDCONF}
-.endif
-
post-patch:
- @${REINPLACE_CMD} -e 's,"make","${GMAKE}",' ${WRKSRC}/setup.ml
+ @${REINPLACE_CMD} -e 's,"install" :: findlib_name,"install" :: "-destdir ${STAGEDIR}${PREFIX}/lib/ocaml/site-lib" :: "-ldconf /dev/null" :: findlib_name,' \
+ ${WRKSRC}/setup.ml
+
+do-configure:
+ (cd ${WRKSRC}; ocaml setup.ml -configure ${CONFIGURE_ARGS})
+
+do-build:
+ (cd ${WRKSRC}; ocaml setup.ml -build)
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${OCAMLFIND_DESTDIR}
+ (cd ${WRKSRC}; ocaml setup.ml -install)
.include <bsd.port.mk>
diff --git a/textproc/ocaml-text/distinfo b/textproc/ocaml-text/distinfo
index c4b1dd7ce305..2942015076d4 100644
--- a/textproc/ocaml-text/distinfo
+++ b/textproc/ocaml-text/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ocaml-text-0.5.tar.gz) = d7fc2ae616130a61f822686a6c366a5a4653d3fd8785c14d57038c9f5643dfc3
-SIZE (ocaml-text-0.5.tar.gz) = 248862
+SHA256 (ocaml-text-0.6.tar.gz) = cfd4d224ec0b776ce462c5ba5cb6e4eae8cf397ede6d3b91add44a05a6520f49
+SIZE (ocaml-text-0.6.tar.gz) = 253162
diff --git a/textproc/ocaml-text/pkg-plist b/textproc/ocaml-text/pkg-plist
index 06550d7d2dc5..803a401049a8 100644
--- a/textproc/ocaml-text/pkg-plist
+++ b/textproc/ocaml-text/pkg-plist
@@ -1,18 +1,42 @@
-%%DOCSDIR%%/api/Encoding.html
-%%DOCSDIR%%/api/Text.html
-%%DOCSDIR%%/api/index.html
-%%DOCSDIR%%/api/index_attributes.html
-%%DOCSDIR%%/api/index_class_types.html
-%%DOCSDIR%%/api/index_classes.html
-%%DOCSDIR%%/api/index_exceptions.html
-%%DOCSDIR%%/api/index_methods.html
-%%DOCSDIR%%/api/index_module_types.html
-%%DOCSDIR%%/api/index_modules.html
-%%DOCSDIR%%/api/index_types.html
-%%DOCSDIR%%/api/index_values.html
-%%DOCSDIR%%/api/style.css
-%%DOCSDIR%%/api/type_Encoding.html
-%%DOCSDIR%%/api/type_Text.html
-@dirrm %%DOCSDIR%%/api
-%%DOCSDIR%%/manual.pdf
-@dirrm %%DOCSDIR%%
+%%OCAML_SITELIBDIR%%/text/META
+%%OCAML_SITELIBDIR%%/text/dlltext-bigarray_stubs.so
+%%OCAML_SITELIBDIR%%/text/dlltext_stubs.so
+%%OCAML_SITELIBDIR%%/text/encoding.cmi
+%%OCAML_SITELIBDIR%%/text/encoding.cmx
+%%OCAML_SITELIBDIR%%/text/encoding.mli
+%%OCAML_SITELIBDIR%%/text/encoding_bigarray.cmi
+%%OCAML_SITELIBDIR%%/text/encoding_bigarray.cmx
+%%OCAML_SITELIBDIR%%/text/encoding_bigarray.mli
+%%OCAML_SITELIBDIR%%/text/libtext-bigarray_stubs.a
+%%OCAML_SITELIBDIR%%/text/libtext_stubs.a
+%%OCAML_SITELIBDIR%%/text/pa_text_env.cmx
+%%OCAML_SITELIBDIR%%/text/pa_text_main.cmx
+%%OCAML_SITELIBDIR%%/text/pa_text_parse.cmx
+%%OCAML_SITELIBDIR%%/text/pa_text_regexp.cmx
+%%OCAML_SITELIBDIR%%/text/pa_text_types.cmx
+%%OCAML_SITELIBDIR%%/text/pa_text_util.cmx
+%%OCAML_SITELIBDIR%%/text/text-bigarray.a
+%%OCAML_SITELIBDIR%%/text/text-bigarray.cma
+%%OCAML_SITELIBDIR%%/text/text-bigarray.cmxa
+%%OCAML_SITELIBDIR%%/text/text-bigarray.cmxs
+%%OCAML_SITELIBDIR%%/text/text-pcre-syntax.a
+%%OCAML_SITELIBDIR%%/text/text-pcre-syntax.cma
+%%OCAML_SITELIBDIR%%/text/text-pcre-syntax.cmxa
+%%OCAML_SITELIBDIR%%/text/text-pcre-syntax.cmxs
+%%OCAML_SITELIBDIR%%/text/text-pcre.a
+%%OCAML_SITELIBDIR%%/text/text-pcre.cma
+%%OCAML_SITELIBDIR%%/text/text-pcre.cmxa
+%%OCAML_SITELIBDIR%%/text/text-pcre.cmxs
+%%OCAML_SITELIBDIR%%/text/text.a
+%%OCAML_SITELIBDIR%%/text/text.cma
+%%OCAML_SITELIBDIR%%/text/text.cmi
+%%OCAML_SITELIBDIR%%/text/text.cmx
+%%OCAML_SITELIBDIR%%/text/text.cmxa
+%%OCAML_SITELIBDIR%%/text/text.cmxs
+%%OCAML_SITELIBDIR%%/text/text.mli
+%%OCAML_SITELIBDIR%%/text/text_pcre.cmi
+%%OCAML_SITELIBDIR%%/text/text_pcre.cmx
+%%OCAML_SITELIBDIR%%/text/text_pcre.mli
+@dirrm %%OCAML_SITELIBDIR%%/text
+@dirrmtry %%OCAML_SITELIBDIR%%
+@dirrmtry lib/ocaml