aboutsummaryrefslogtreecommitdiff
path: root/textproc/ocaml-text
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-07-28 10:27:27 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-07-28 10:27:27 +0000
commitf4aa9e3bcefa2c2f96f2a10ddc17905728e33fbe (patch)
tree6f320674ecbbfd25e6def618a26f15121f68b562 /textproc/ocaml-text
parentc9855c03b8f4458c55ca861a5c5d29ea1cddb2c2 (diff)
downloadports-f4aa9e3bcefa2c2f96f2a10ddc17905728e33fbe.tar.gz
ports-f4aa9e3bcefa2c2f96f2a10ddc17905728e33fbe.zip
Unbreak parallel builds and cleanup Makefile while I am at it.
Notes
Notes: svn path=/head/; revision=323818
Diffstat (limited to 'textproc/ocaml-text')
-rw-r--r--textproc/ocaml-text/Makefile33
1 files changed, 14 insertions, 19 deletions
diff --git a/textproc/ocaml-text/Makefile b/textproc/ocaml-text/Makefile
index 6f406c977c3d..159c566ba4a5 100644
--- a/textproc/ocaml-text/Makefile
+++ b/textproc/ocaml-text/Makefile
@@ -11,35 +11,27 @@ DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
MAINTAINER= jaapb@kerguelen.org
COMMENT= OCaml library for dealing with text
-DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
-
-HAS_CONFIGURE= yes
-CONFIGURE_ARGS= --docdir ${DOCSDIR} --prefix ${PREFIX} --mandir ${PREFIX}/man
-USE_GMAKE= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --docdir ${DOCSDIR} --prefix ${PREFIX} --mandir ${PREFIX}/man
+USES= gmake
USE_OCAML= yes
USE_OCAML_FINDLIB= yes
USE_OCAML_LDCONFIG= yes
USE_OCAMLFIND_PLIST= yes
+SA_DIR= ${LOCALBASE}/${OCAML_SITELIBDIR}
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+
OPTIONS_DEFINE= PCRE
OPTIONS_DEFAULT= PCRE
-SA_DIR= ${LOCALBASE}/${OCAML_SITELIBDIR}
-
-.include <bsd.port.pre.mk>
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPCRE}
-CONFIGURE_ARGS+= --enable-pcre
-BUILD_DEPENDS+= ${SA_DIR}/pcre/pcre.a:${PORTSDIR}/devel/ocaml-pcre
-RUN_DEPENDS+= ${SA_DIR}/pcre/pcre.a:${PORTSDIR}/devel/ocaml-pcre
-.else
-CONFIGURE_ARGS+= --disable-pcre
-.endif
+PCRE_CONFIGURE_ENABLE= pcre
+PCRE_BUILD_DEPENDS= ${SA_DIR}/pcre/pcre.a:${PORTSDIR}/devel/ocaml-pcre
+PCRE_RUN_DEPENDS= ${SA_DIR}/pcre/pcre.a:${PORTSDIR}/devel/ocaml-pcre
post-extract:
-# For nonstandard prefixes
+# For non-standard prefixes
.if !exists(${OCAMLFIND_DESTDIR})
${MKDIR} ${OCAMLFIND_DESTDIR}
.endif
@@ -47,4 +39,7 @@ post-extract:
${TOUCH} ${OCAMLFIND_LDCONF}
.endif
-.include <bsd.port.post.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's,"make","${GMAKE}",' ${WRKSRC}/setup.ml
+
+.include <bsd.port.mk>