aboutsummaryrefslogtreecommitdiff
path: root/textproc/openfts
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2003-08-19 13:53:24 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2003-08-19 13:53:24 +0000
commit63a0018287319d115b160aa4c01e5d4e7cf19867 (patch)
tree9fd071a4b8c52fb709e3190664c9ad5d89a595b7 /textproc/openfts
parentf4296f839be6ddbfcc67dfe638b35a7b449aa2cd (diff)
downloadports-63a0018287319d115b160aa4c01e5d4e7cf19867.tar.gz
ports-63a0018287319d115b160aa4c01e5d4e7cf19867.zip
o Remove mis-addedd $PKGNAMEPREFIX.
o Add patches for -w clean.
Notes
Notes: svn path=/head/; revision=87293
Diffstat (limited to 'textproc/openfts')
-rw-r--r--textproc/openfts/Makefile2
-rw-r--r--textproc/openfts/files/patch-Index.pm11
-rw-r--r--textproc/openfts/files/patch-PorterEng.pm11
3 files changed, 23 insertions, 1 deletions
diff --git a/textproc/openfts/Makefile b/textproc/openfts/Makefile
index 515f9ff9f5f9..e476555a0eb7 100644
--- a/textproc/openfts/Makefile
+++ b/textproc/openfts/Makefile
@@ -7,10 +7,10 @@
PORTNAME= openfts
PORTVERSION= 0.34
+PORTREVISION= 1
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= openfts
-PKGNAMEPREFIX= p5-
DISTNAME= Search-OpenFTS-${PORTVERSION}
MAINTAINER= kuriyama@FreeBSD.org
diff --git a/textproc/openfts/files/patch-Index.pm b/textproc/openfts/files/patch-Index.pm
new file mode 100644
index 000000000000..0148c7ea9c1a
--- /dev/null
+++ b/textproc/openfts/files/patch-Index.pm
@@ -0,0 +1,11 @@
+--- OpenFTS/Index.pm.orig Wed Jul 24 02:15:37 2002
++++ OpenFTS/Index.pm Tue Aug 19 20:28:53 2003
+@@ -201,7 +201,7 @@
+
+ foreach my $i ( 0..$#{$rv} ) {
+ my $param = $rv->[$i]{param};
+- if ( length $param ) {
++ if ( $param and length $param ) {
+ $rv->[$i]{param} = eval $param;
+ die "Can't eval '$param': $@" if $@;
+ }
diff --git a/textproc/openfts/files/patch-PorterEng.pm b/textproc/openfts/files/patch-PorterEng.pm
new file mode 100644
index 000000000000..1a461df17b9a
--- /dev/null
+++ b/textproc/openfts/files/patch-PorterEng.pm
@@ -0,0 +1,11 @@
+--- OpenFTS/Dict/PorterEng.pm.orig Sat Apr 6 00:37:18 2002
++++ OpenFTS/Dict/PorterEng.pm Tue Aug 19 20:54:05 2003
+@@ -186,7 +186,7 @@
+ my $constname;
+ ($constname = $AUTOLOAD) =~ s/.*:://;
+ croak "& not defined" if $constname eq 'constant';
+- my $val = constant($constname, @_ ? $_[0] : 0);
++ my $val = constant($constname, (@_ and $_[0] =~ /^\d+$/) ? $_[0] : 0);
+ if ($! != 0) {
+ if ($! =~ /Invalid/) {
+ $AutoLoader::AUTOLOAD = $AUTOLOAD;