aboutsummaryrefslogtreecommitdiff
path: root/textproc/openfts
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-06-20 09:20:50 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-06-20 09:20:50 +0000
commit6bf779f83dd48197614f473fe70fcb7837f50d16 (patch)
treea2a4ae55394b5e7341864d330b4f9d345fb44fe4 /textproc/openfts
parent656d1a0cee948bc0d7c8f1dc162218fe38cb0f3c (diff)
downloadports-6bf779f83dd48197614f473fe70fcb7837f50d16.tar.gz
ports-6bf779f83dd48197614f473fe70fcb7837f50d16.zip
- Upgrade to 0.37;
- Set RUN_DEPENDS; - Install docs and examples. Approved by: maintainer.
Notes
Notes: svn path=/head/; revision=111852
Diffstat (limited to 'textproc/openfts')
-rw-r--r--textproc/openfts/Makefile22
-rw-r--r--textproc/openfts/distinfo4
-rw-r--r--textproc/openfts/files/patch-doc::primer.html33
-rw-r--r--textproc/openfts/pkg-plist20
4 files changed, 74 insertions, 5 deletions
diff --git a/textproc/openfts/Makefile b/textproc/openfts/Makefile
index c80a55e9f0fb..ec8ba2840736 100644
--- a/textproc/openfts/Makefile
+++ b/textproc/openfts/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openfts
-PORTVERSION= 0.36
+PORTVERSION= 0.37
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= openfts
@@ -15,8 +15,11 @@ DISTNAME= Search-OpenFTS-${PORTVERSION}
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Open Source Full Text Search engine
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg \
+ ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
+ ${LOCALBASE}/lib/postgresql/tsearch2.so:${PORTSDIR}/databases/postgresql-contrib
+
PERL_CONFIGURE= yes
-USE_REINPLACE= yes
MAN3= Search::OpenFTS.3 Search::OpenFTS::Base.3 \
Search::OpenFTS::Dict::PorterEng.3 Search::OpenFTS::Dict::Snowball.3 \
@@ -24,11 +27,24 @@ MAN3= Search::OpenFTS.3 Search::OpenFTS::Base.3 \
Search::OpenFTS::Index.3 Search::OpenFTS::Morph::ISpell.3 \
Search::OpenFTS::Parser.3
+.if !defined(NOPORTDOCS)
+PORTDOCS= Changes INSTALL README primer.html
+
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/examples/* ${EXAMPLESDIR}
+ @${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
+ @${CP} -p ${WRKSRC}/doc/primer.html ${WRKSRC}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
+
# Sample DB initialization.
DBNAME?= openfts
create-database:
createdb ${DBNAME}
- cd ${PREFIX}/share/postgresql/contrib && \
+ cd ${LOCALBASE}/share/postgresql/contrib && \
psql ${DBNAME} < tsearch.sql && \
psql ${DBNAME} < openfts.sql
diff --git a/textproc/openfts/distinfo b/textproc/openfts/distinfo
index 5530fc05d99a..44d18910722a 100644
--- a/textproc/openfts/distinfo
+++ b/textproc/openfts/distinfo
@@ -1,2 +1,2 @@
-MD5 (Search-OpenFTS-0.36.tar.gz) = 5f9a851fceafb3e3c549af4706cac635
-SIZE (Search-OpenFTS-0.36.tar.gz) = 78947
+MD5 (Search-OpenFTS-0.37.tar.gz) = e023b09b8a2cff9b7716dfa63fe9c1d1
+SIZE (Search-OpenFTS-0.37.tar.gz) = 79507
diff --git a/textproc/openfts/files/patch-doc::primer.html b/textproc/openfts/files/patch-doc::primer.html
new file mode 100644
index 000000000000..64283e15898f
--- /dev/null
+++ b/textproc/openfts/files/patch-doc::primer.html
@@ -0,0 +1,33 @@
+--- doc/primer.html.orig Mon Jun 14 12:22:40 2004
++++ doc/primer.html Thu Jun 17 21:50:29 2004
+@@ -640,7 +640,7 @@
+ Change to the directory where <b>tsearch2</b> is. This is
+ a PostgreSQL module available under the <b>contrib</b> directory.
+ <code><pre>
+-$ cd PGSQL_SRC_HOME/contrib/tsearch2
++$ cd /usr/local/share/postgresql/contrib
+ </pre></code>
+ </li>
+ <li>
+@@ -650,7 +650,7 @@
+ </li>
+ <li>
+ <code><pre>
+-$ cd /usr/local/src/Search-OpenFTS-0.37/examples
++$ cd /usr/local/share/examples/Search-OpenFTS/
+ </pre></code>
+ </li>
+ <li>
+@@ -660,7 +660,11 @@
+ </li>
+ <li>
+ <code><pre>
+-$ ./index.pl testfts file1 [file2 [...] ]
++$ ./index.pl testfts
++file1
++[file2
++ [...] ]
++
+ </pre></code>
+ </li>
+ <li>
diff --git a/textproc/openfts/pkg-plist b/textproc/openfts/pkg-plist
index 8e5aea2502f8..b34acca63d9a 100644
--- a/textproc/openfts/pkg-plist
+++ b/textproc/openfts/pkg-plist
@@ -17,6 +17,23 @@
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Parser/Parser.bs
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Parser/Parser.so
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Parser/autosplit.ix
+%%PORTDOCS%%%%EXAMPLESDIR%%/Dict/DecimalDict.pm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Dict/EngStem.pm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Dict/IntegerDict.pm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Dict/StemSnowball.pm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Dict/english.stop
+%%PORTDOCS%%%%EXAMPLESDIR%%/Dict/russian.stop
+%%PORTDOCS%%%%EXAMPLESDIR%%/README
+%%PORTDOCS%%%%EXAMPLESDIR%%/README.INSIDE
+%%PORTDOCS%%%%EXAMPLESDIR%%/index.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/init-custom.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/init.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/parser/parser-test-1.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/parser/parser-test-2.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/parser/test.html
+%%PORTDOCS%%%%EXAMPLESDIR%%/search.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/simple_parser.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/testdict.pl
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Dict/PorterEng
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Dict
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/OpenFTS/Morph/ISpell
@@ -28,3 +45,6 @@
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Search/OpenFTS
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Search 2>/dev/null
@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search 2>/dev/null
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/Dict
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/parser
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%