aboutsummaryrefslogtreecommitdiff
path: root/textproc/openfts
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2010-05-23 00:05:18 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2010-05-23 00:05:18 +0000
commitdd3202e53bdc3e1bc87ffe3e74b3eab5f4d10037 (patch)
tree6293e93811bfe10088cb79100334334aad08a574 /textproc/openfts
parent69fc8209eeab5ba54b254a9f54bc492978926f37 (diff)
downloadports-dd3202e53bdc3e1bc87ffe3e74b3eab5f4d10037.tar.gz
ports-dd3202e53bdc3e1bc87ffe3e74b3eab5f4d10037.zip
Upgrade to 0.40.
Notes
Notes: svn path=/head/; revision=254869
Diffstat (limited to 'textproc/openfts')
-rw-r--r--textproc/openfts/Makefile6
-rw-r--r--textproc/openfts/distinfo6
-rw-r--r--textproc/openfts/files/patch-doc::primer.html8
-rw-r--r--textproc/openfts/files/patch-flexparser.l11
4 files changed, 20 insertions, 11 deletions
diff --git a/textproc/openfts/Makefile b/textproc/openfts/Makefile
index a21bedff4d8d..d325c68496b0 100644
--- a/textproc/openfts/Makefile
+++ b/textproc/openfts/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= openfts
-PORTVERSION= 0.39
-PORTREVISION= 2
+PORTVERSION= 0.40
CATEGORIES= textproc perl5
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/OpenFTS-perl%2C%20v${PORTVERSION}
DISTNAME= Search-OpenFTS-${PORTVERSION}
@@ -15,8 +14,7 @@ DISTNAME= Search-OpenFTS-${PORTVERSION}
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Open Source Full Text Search engine
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
- ${LOCALBASE}/lib/postgresql/tsearch2.so:${PORTSDIR}/databases/postgresql82-contrib \
+RUN_DEPENDS= ${LOCALBASE}/lib/postgresql/tsearch2.so:${PORTSDIR}/databases/postgresql82-contrib \
${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
PERL_CONFIGURE= yes
diff --git a/textproc/openfts/distinfo b/textproc/openfts/distinfo
index 89f4daa6cbe3..340e0b3352e1 100644
--- a/textproc/openfts/distinfo
+++ b/textproc/openfts/distinfo
@@ -1,3 +1,3 @@
-MD5 (Search-OpenFTS-0.39.tar.gz) = 32bec887b55ca5cd26bd529007ac59c1
-SHA256 (Search-OpenFTS-0.39.tar.gz) = d46cd4434014001b9025cdcb3d393f5790e188c0be47f0ec1b9f228cfb4fe740
-SIZE (Search-OpenFTS-0.39.tar.gz) = 81523
+MD5 (Search-OpenFTS-0.40.tar.gz) = 3461d8600c9c811fb7af856f2c862fcc
+SHA256 (Search-OpenFTS-0.40.tar.gz) = d098806920f458e8e3ae9f99d94dc11cc531ead3bb6b68c4e5ab549d7aa3a2c7
+SIZE (Search-OpenFTS-0.40.tar.gz) = 80438
diff --git a/textproc/openfts/files/patch-doc::primer.html b/textproc/openfts/files/patch-doc::primer.html
index cd42b7b4a29d..d7306923f853 100644
--- a/textproc/openfts/files/patch-doc::primer.html
+++ b/textproc/openfts/files/patch-doc::primer.html
@@ -1,5 +1,5 @@
---- doc/primer.html.orig Mon Jun 14 12:22:40 2004
-+++ doc/primer.html Thu Jun 17 21:50:29 2004
+--- doc/primer.html.orig 2009-12-04 21:27:41.000000000 +0900
++++ doc/primer.html 2010-05-23 00:32:47.534983282 +0900
@@ -640,7 +640,7 @@
Change to the directory where <b>tsearch2</b> is. This is
a PostgreSQL module available under the <b>contrib</b> directory.
@@ -13,8 +13,8 @@
</li>
<li>
<code><pre>
--$ cd /usr/local/src/Search-OpenFTS-0.39/examples
-+$ cd /usr/local/share/examples/Search-OpenFTS/
+-$ cd /usr/local/src/Search-OpenFTS-0.40/examples
++$ cd /usr/local/share/examples/Search-OpenFTS
</pre></code>
</li>
<li>
diff --git a/textproc/openfts/files/patch-flexparser.l b/textproc/openfts/files/patch-flexparser.l
new file mode 100644
index 000000000000..957d34d162f6
--- /dev/null
+++ b/textproc/openfts/files/patch-flexparser.l
@@ -0,0 +1,11 @@
+--- OpenFTS/flexparser.l.orig 2010-05-23 01:15:15.558693826 +0900
++++ OpenFTS/flexparser.l 2010-05-23 01:15:51.544638807 +0900
+@@ -15,7 +15,7 @@
+
+ /* redefine macro for read limited length */
+ #define YY_INPUT(buf,result,max_size) \
+- if ( YY_CURRENT_BUFFER_LVALUE->yy_is_interactive ) { \
++ if ( yy_current_buffer->yy_is_interactive ) { \
+ int c = '*', n; \
+ for ( n = 0; n < max_size && \
+ (c = getc( fts_yyin )) != EOF && c != '\n'; ++n ) \