aboutsummaryrefslogtreecommitdiff
path: root/textproc/openjade
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2003-08-05 03:25:44 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2003-08-05 03:25:44 +0000
commit2f49c29328f7e21b4bc7be5d04fe39b0816ffec2 (patch)
treede824e9dbff78b346fc068b5e191e9720f19c28c /textproc/openjade
parentabacdcce30a192fcf797ef2579475d365916bb0d (diff)
downloadports-2f49c29328f7e21b4bc7be5d04fe39b0816ffec2.tar.gz
ports-2f49c29328f7e21b4bc7be5d04fe39b0816ffec2.zip
Add patches for gcc33 from sourceforge.
Notes
Notes: svn path=/head/; revision=86324
Diffstat (limited to 'textproc/openjade')
-rw-r--r--textproc/openjade/Makefile2
-rw-r--r--textproc/openjade/files/patch-GroveApp.h14
-rw-r--r--textproc/openjade/files/patch-GroveBuilder.cxx42
-rw-r--r--textproc/openjade/files/patch-Node.h26
4 files changed, 83 insertions, 1 deletions
diff --git a/textproc/openjade/Makefile b/textproc/openjade/Makefile
index a26607d79902..560fcaa27c87 100644
--- a/textproc/openjade/Makefile
+++ b/textproc/openjade/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openjade
PORTVERSION= 1.3.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/textproc/openjade/files/patch-GroveApp.h b/textproc/openjade/files/patch-GroveApp.h
new file mode 100644
index 000000000000..b261426d23e1
--- /dev/null
+++ b/textproc/openjade/files/patch-GroveApp.h
@@ -0,0 +1,14 @@
+--- spgrove/GroveApp.h.orig Sun May 2 21:57:37 1999
++++ spgrove/GroveApp.h Tue Aug 5 11:27:44 2003
+@@ -7,9 +7,9 @@
+ #pragma interface
+ #endif
+
+-#include "ParserApp.h"
++#include <OpenSP/ParserApp.h>
+ #include "GroveBuilder.h"
+-#include "HashTable.h"
++#include <OpenSP/HashTable.h>
+
+ #ifdef SP_NAMESPACE
+ namespace SP_NAMESPACE {
diff --git a/textproc/openjade/files/patch-GroveBuilder.cxx b/textproc/openjade/files/patch-GroveBuilder.cxx
new file mode 100644
index 000000000000..3bd85946768d
--- /dev/null
+++ b/textproc/openjade/files/patch-GroveBuilder.cxx
@@ -0,0 +1,42 @@
+--- spgrove/GroveBuilder.cxx.orig Sun Nov 17 03:01:12 2002
++++ spgrove/GroveBuilder.cxx Tue Aug 5 11:27:44 2003
+@@ -4,26 +4,24 @@
+ // FIXME location for SgmlDocument node.
+
+ #include "config.h"
+-#include "Boolean.h"
++#include <OpenSP/Boolean.h>
+ #include "Node.h"
+-#include "Resource.h"
+-#include "Ptr.h"
+-#include "xnew.h"
+-#include "Event.h"
++#include <OpenSP/Resource.h>
++#include <OpenSP/Ptr.h>
++#include <OpenSP/xnew.h>
++#include <OpenSP/Event.h>
+ #include "GroveBuilder.h"
+-#include "ErrorCountEventHandler.h"
+-#include "OutputCharStream.h"
+-#include "MessageFormatter.h"
+-#include "Dtd.h"
+-#include "Syntax.h"
+-#include "Attribute.h"
+-#include "Vector.h"
++#include <OpenSP/ErrorCountEventHandler.h>
++#include <OpenSP/OutputCharStream.h>
++#include <OpenSP/MessageFormatter.h>
++#include <OpenSP/Dtd.h>
++#include <OpenSP/Syntax.h>
++#include <OpenSP/Attribute.h>
++#include <OpenSP/Vector.h>
+ #include "LocNode.h"
+ #include "SdNode.h"
+ #include "threads.h"
+-#include "macros.h"
+-#include <assert.h>
+-#include <stdio.h>
++#include <OpenSP/macros.h>
+
+ #ifdef _MSC_VER
+ #pragma warning ( disable : 4250 ) // inherits via dominance
diff --git a/textproc/openjade/files/patch-Node.h b/textproc/openjade/files/patch-Node.h
new file mode 100644
index 000000000000..202cc0be4076
--- /dev/null
+++ b/textproc/openjade/files/patch-Node.h
@@ -0,0 +1,26 @@
+--- grove/Node.h.orig Mon Oct 21 06:47:24 2002
++++ grove/Node.h Tue Aug 5 11:27:44 2003
+@@ -8,7 +8,8 @@
+ #endif
+
+ #include <stddef.h>
+-#include "IList.h"
++#include <limits.h>
++#include <OpenSP/IList.h>
+
+ #ifdef SP_USE_DLL
+ #ifdef BUILD_LIBGROVE
+@@ -34,10 +35,10 @@
+ #endif
+
+ #ifdef SP_MULTI_BYTE
+-#ifdef SP_WCHAR_T_USHORT
+-typedef wchar_t GroveChar;
+-#else
++#if UINT_MAX >= 0xffffffffL /* 2^32 - 1 */
+ typedef unsigned int GroveChar;
++#else
++typedef unsigned long GroveChar;
+ #endif
+ #else /* not SP_MULTI_BYTE */
+ typedef unsigned char GroveChar;