aboutsummaryrefslogtreecommitdiff
path: root/textproc/opensp/Makefile
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2003-01-06 09:08:19 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2003-01-06 09:08:19 +0000
commit4f3ac38ebb8b54978cba0c108457c9df633f7d76 (patch)
tree497c7a14205614985bfb374d9aa368ec877f6b11 /textproc/opensp/Makefile
parent3420c5a55ca9490dd09970f9384be45fde24c534 (diff)
Notes
Diffstat (limited to 'textproc/opensp/Makefile')
-rw-r--r--textproc/opensp/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/textproc/opensp/Makefile b/textproc/opensp/Makefile
new file mode 100644
index 000000000000..e91e4f08905b
--- /dev/null
+++ b/textproc/opensp/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: OpenSP
+# Date created: Jan 6, 2003
+# Whom: kuriyama
+#
+# $FreeBSD$
+#
+
+PORTNAME= OpenSP
+PORTVERSION= 1.5
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= openjade
+
+MAINTAINER= kuriyama@FreeBSD.org
+
+USE_GMAKE= YES
+USE_LIBTOOL= YES
+USE_PERL5= yes
+CONFIGURE_ARGS= --enable-default-catalog=${PREFIX}/share/sgml/catalog \
+ --datadir=${PREFIX}/share/sgml/openjade
+INSTALLS_SHLIB= yes
+
+MAN1= onsgmls.1 osgmlnorm.1 ospam.1 ospent.1 osx.1
+
+.include <bsd.port.pre.mk>
+
+# This port cannot be CFLAGS safe, using optimizations such as
+# 'march=-mpentium -Os' produces core dumps with certain input files
+# Therefore, we'd better remove all machine optimizations and any -O
+# other than -O{0,1,}. Idea taken from palm/prc-tools-gcc.
+CPPFLAGS:= -O ${CFLAGS:N-O*:N-m*}
+
+.include <bsd.port.post.mk>