aboutsummaryrefslogtreecommitdiff
path: root/textproc/opensp
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2003-07-18 05:27:31 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2003-07-18 05:27:31 +0000
commit707e0903552a1079cce9015600a34c66bc986952 (patch)
treee8b80ae7e77d9a7c1a8a67bde28a696b6457df54 /textproc/opensp
parentb4d9f5dd70ac0068f3ba40bc9ddafb980807462c (diff)
downloadports-707e0903552a1079cce9015600a34c66bc986952.tar.gz
ports-707e0903552a1079cce9015600a34c66bc986952.zip
Add explicit cast to C++ include files to unbreak openjade on
gcc 3.3.
Notes
Notes: svn path=/head/; revision=85104
Diffstat (limited to 'textproc/opensp')
-rw-r--r--textproc/opensp/Makefile1
-rw-r--r--textproc/opensp/files/patch-Ptr.cxx11
-rw-r--r--textproc/opensp/files/patch-Ptr.h10
3 files changed, 22 insertions, 0 deletions
diff --git a/textproc/opensp/Makefile b/textproc/opensp/Makefile
index d3fd2132573b..67b573ad2752 100644
--- a/textproc/opensp/Makefile
+++ b/textproc/opensp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= OpenSP
PORTVERSION= 1.5
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= openjade
diff --git a/textproc/opensp/files/patch-Ptr.cxx b/textproc/opensp/files/patch-Ptr.cxx
new file mode 100644
index 000000000000..400534a7f53f
--- /dev/null
+++ b/textproc/opensp/files/patch-Ptr.cxx
@@ -0,0 +1,11 @@
+--- include/Ptr.cxx.orig Fri Jul 18 14:11:13 2003
++++ include/Ptr.cxx Fri Jul 18 14:11:32 2003
+@@ -19,7 +19,7 @@
+ Ptr<T>::~Ptr()
+ {
+ if (ptr_) {
+- if (ptr_->unref())
++ if (((Resource*)ptr_)->unref())
+ delete ptr_;
+ ptr_ = 0;
+ }
diff --git a/textproc/opensp/files/patch-Ptr.h b/textproc/opensp/files/patch-Ptr.h
new file mode 100644
index 000000000000..9bef362ff78c
--- /dev/null
+++ b/textproc/opensp/files/patch-Ptr.h
@@ -0,0 +1,10 @@
+--- include/Ptr.h.orig Fri Jul 18 14:11:08 2003
++++ include/Ptr.h Fri Jul 18 14:11:22 2003
+@@ -5,6 +5,7 @@
+ #define Ptr_INCLUDED 1
+
+ #include "Boolean.h"
++#include "Resource.h"
+
+ // T must have Resource as a public base class
+ // T may be an incomplete type