aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Algorithm-RabinKarp
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-24 17:47:11 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-24 17:47:11 +0000
commitfb3f2c89204e07f4e0778551ca6ad5b7fccfb3c1 (patch)
treeff25ebd851f98010a86fec15d179b12ccf18894a /textproc/p5-Algorithm-RabinKarp
parentbd57d8de936cbee750045cc3a9199525df26130f (diff)
downloadports-fb3f2c89204e07f4e0778551ca6ad5b7fccfb3c1.tar.gz
ports-fb3f2c89204e07f4e0778551ca6ad5b7fccfb3c1.zip
Adding port textproc/p5-Algorithm-RabinKarp, an implementation of Rabin and Karp's streaming hash, as described
in "Winnowing: Local Algorithms for Document Fingerprinting" by Schleimer, Wilkerson, and Aiken. Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=163295
Diffstat (limited to 'textproc/p5-Algorithm-RabinKarp')
-rw-r--r--textproc/p5-Algorithm-RabinKarp/Makefile28
-rw-r--r--textproc/p5-Algorithm-RabinKarp/distinfo3
-rw-r--r--textproc/p5-Algorithm-RabinKarp/pkg-descr18
-rw-r--r--textproc/p5-Algorithm-RabinKarp/pkg-plist5
4 files changed, 54 insertions, 0 deletions
diff --git a/textproc/p5-Algorithm-RabinKarp/Makefile b/textproc/p5-Algorithm-RabinKarp/Makefile
new file mode 100644
index 000000000000..fab4c8d38ceb
--- /dev/null
+++ b/textproc/p5-Algorithm-RabinKarp/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Algorithm-RabinKarp
+# Date created: 24 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Algorithm-RabinKarp
+PORTVERSION= 0.36
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Algorithm
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Rabin-Karp streaming hash
+
+MAN3= Algorithm::RabinKarp.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requres at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Algorithm-RabinKarp/distinfo b/textproc/p5-Algorithm-RabinKarp/distinfo
new file mode 100644
index 000000000000..5aa3a07912e4
--- /dev/null
+++ b/textproc/p5-Algorithm-RabinKarp/distinfo
@@ -0,0 +1,3 @@
+MD5 (Algorithm-RabinKarp-0.36.tar.gz) = 24c57956e79634347bf32cdd1897d50f
+SHA256 (Algorithm-RabinKarp-0.36.tar.gz) = 8f602cb66c02c09d075f845e2893be1c23ea048057c8f3c71dbf680102ee8d42
+SIZE (Algorithm-RabinKarp-0.36.tar.gz) = 4255
diff --git a/textproc/p5-Algorithm-RabinKarp/pkg-descr b/textproc/p5-Algorithm-RabinKarp/pkg-descr
new file mode 100644
index 000000000000..40d892395f70
--- /dev/null
+++ b/textproc/p5-Algorithm-RabinKarp/pkg-descr
@@ -0,0 +1,18 @@
+This is an implementation of Rabin and Karp's streaming hash, as described
+in "Winnowing: Local Algorithms for Document Fingerprinting" by Schleimer,
+Wilkerson, and Aiken. Following the suggestion of Schleimer, I am using
+their second equation:
+
+ $H[ $c[2..$k + 1] ] = (( $H[ $c[1..$k] ] - $c[1] ** $k ) + $c[$k+1] ) * $k
+
+The results of this hash encodes information about the next k values in
+the stream (hense k-gram.) This means for any given stream of length n
+integer values (or characters), you will get back n - k + 1 hash values.
+
+For best results, you will want to create a code generator that filters
+your data to remove all unnecessary information. For example, in a large
+english document, you should probably remove all white space, as well as
+removing all capitalization.
+
+WWW: http://search.cpan.org/dist/Algorithm-RabinKarp
+Author: Norman Nunley <nnunley@gmail.com>
diff --git a/textproc/p5-Algorithm-RabinKarp/pkg-plist b/textproc/p5-Algorithm-RabinKarp/pkg-plist
new file mode 100644
index 000000000000..8cc099bcea14
--- /dev/null
+++ b/textproc/p5-Algorithm-RabinKarp/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Algorithm/RabinKarp.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/RabinKarp/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/RabinKarp
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm
+@dirrmtry %%SITE_PERL%%/Algorithm