aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-CSS-SAC
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-12-25 23:56:57 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-12-25 23:56:57 +0000
commit8b339332ea4c8a5f3b80411c1402d1ebf1d14e17 (patch)
tree23175faa544e44312b8306dfa69085ced4bd3d32 /textproc/p5-CSS-SAC
parent0b1b9c2c9b53f593b6fbf4e0a1e4f6befc97c98e (diff)
downloadports-8b339332ea4c8a5f3b80411c1402d1ebf1d14e17.tar.gz
ports-8b339332ea4c8a5f3b80411c1402d1ebf1d14e17.zip
- Simplify dependency
- Fix Bareword "_out_" problem - Bump PORTREVISION PR: 141151 Submitted by: leeym Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=246661
Diffstat (limited to 'textproc/p5-CSS-SAC')
-rw-r--r--textproc/p5-CSS-SAC/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/textproc/p5-CSS-SAC/Makefile b/textproc/p5-CSS-SAC/Makefile
index 540bcfa177df..1aba6e2f8a93 100644
--- a/textproc/p5-CSS-SAC/Makefile
+++ b/textproc/p5-CSS-SAC/Makefile
@@ -7,6 +7,7 @@
PORTNAME= CSS-SAC
PORTVERSION= 0.08
+PORTREVISION= 1
CATEGORIES= textproc perl5 www
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,9 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= SAC CSS (Simple API for CSS) parser
-BUILD_DEPENDS= ${SITE_PERL}/Text/Balanced.pm:${PORTSDIR}/textproc/p5-Text-Balanced \
- ${SITE_PERL}/Class/ArrayObjects.pm:${PORTSDIR}/devel/p5-Class-ArrayObjects
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= p5-Class-ArrayObjects>=0.04:${PORTSDIR}/devel/p5-Class-ArrayObjects
+BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
@@ -36,4 +36,9 @@ MAN3= CSS::SAC.3 CSS::SAC::Condition.3 \
CSS::SAC::SelectorFactory.3 CSS::SAC::SelectorList.3 \
CSS::SAC::TestWriter.3 CSS::SAC::Writer.3
+# Bareword "_out_" not allowed while "strict subs"
+post-patch:
+ @${REINPLACE_CMD} -e "s,_out_,'_out_',g" ${WRKSRC}/lib/CSS/SAC/TestWriter.pm
+ @${FIND} ${WRKSRC} -name "*.bak" -delete
+
.include <bsd.port.mk>