aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-CSS
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-07-21 12:23:04 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-07-21 12:23:04 +0000
commit97bbe4de85f5944451c5b2d9c05234e2a47e5ff9 (patch)
tree6c858d1a2392e5e49b372d7accae24094de22fbb /textproc/p5-CSS
parent08e714533ed2704f75a29a76740cf66d67b00c8f (diff)
downloadports-97bbe4de85f5944451c5b2d9c05234e2a47e5ff9.tar.gz
ports-97bbe4de85f5944451c5b2d9c05234e2a47e5ff9.zip
Add p5-CSS 1.07, object oriented access to Cascading Style Sheets (CSS).
PR: ports/100640 Submitted by: chinsan <chinsan.tw at gmail.com>
Notes
Notes: svn path=/head/; revision=168361
Diffstat (limited to 'textproc/p5-CSS')
-rw-r--r--textproc/p5-CSS/Makefile32
-rw-r--r--textproc/p5-CSS/distinfo3
-rw-r--r--textproc/p5-CSS/pkg-descr5
-rw-r--r--textproc/p5-CSS/pkg-plist19
4 files changed, 59 insertions, 0 deletions
diff --git a/textproc/p5-CSS/Makefile b/textproc/p5-CSS/Makefile
new file mode 100644
index 000000000000..a161b8387f5c
--- /dev/null
+++ b/textproc/p5-CSS/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-CSS
+# Date created: 2006/07/21
+# Whom: chinsan <chinsan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= CSS
+PORTVERSION= 1.07
+CATEGORIES= textproc www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= CSS
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= Object oriented access to Cascading Style Sheets (CSS)
+
+BUILD_DEPENDS= p5-Parse-RecDescent>=1.94:${PORTSDIR}/devel/p5-Parse-RecDescent
+
+MAN3= CSS.3 CSS::Value.3 CSS::Parse::Compiled.3 CSS::Property.3 CSS::Parse::Heavy.3 \
+ CSS::Parse::PRDGrammar.3 CSS::Style.3 CSS::Parse::Lite.3 CSS::Selector.3 \
+ CSS::Adaptor::Debug.3 CSS::Adaptor::Pretty.3 CSS::Parse.3 CSS::Adaptor.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-CSS/distinfo b/textproc/p5-CSS/distinfo
new file mode 100644
index 000000000000..7d231c76674f
--- /dev/null
+++ b/textproc/p5-CSS/distinfo
@@ -0,0 +1,3 @@
+MD5 (CSS-1.07.tar.gz) = c4f08d2d2ab82c00b1a0d42754d9aef1
+SHA256 (CSS-1.07.tar.gz) = 3fc8f4176a25481f9e7f34162586b6f7db56117dd05ccf99529b7193df08326b
+SIZE (CSS-1.07.tar.gz) = 33782
diff --git a/textproc/p5-CSS/pkg-descr b/textproc/p5-CSS/pkg-descr
new file mode 100644
index 000000000000..bc0603b0f82f
--- /dev/null
+++ b/textproc/p5-CSS/pkg-descr
@@ -0,0 +1,5 @@
+This module can be used, along with a CSS::Parse::* module, to parse CSS
+data and represent it as a tree of objects. Using a CSS::Adaptor::* module,
+the CSS data tree can then be transformed into other formats.
+
+WWW: http://search.cpan.org/dist/CSS/
diff --git a/textproc/p5-CSS/pkg-plist b/textproc/p5-CSS/pkg-plist
new file mode 100644
index 000000000000..70ddd50fc642
--- /dev/null
+++ b/textproc/p5-CSS/pkg-plist
@@ -0,0 +1,19 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/CSS/.packlist
+%%SITE_PERL%%/CSS.pm
+%%SITE_PERL%%/CSS/Value.pm
+%%SITE_PERL%%/CSS/Property.pm
+%%SITE_PERL%%/CSS/Style.pm
+%%SITE_PERL%%/CSS/Selector.pm
+%%SITE_PERL%%/CSS/Parse.pm
+%%SITE_PERL%%/CSS/Adaptor.pm
+%%SITE_PERL%%/CSS/Parse/Compiled.pm
+%%SITE_PERL%%/CSS/Parse/PRDGrammar.pm
+%%SITE_PERL%%/CSS/Parse/Heavy.pm
+%%SITE_PERL%%/CSS/Parse/Lite.pm
+%%SITE_PERL%%/CSS/Parse/CompiledGrammar.pm
+%%SITE_PERL%%/CSS/Adaptor/Debug.pm
+%%SITE_PERL%%/CSS/Adaptor/Pretty.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CSS
+@dirrmtry %%SITE_PERL%%/CSS/Parse
+@dirrmtry %%SITE_PERL%%/CSS/Adaptor
+@dirrmtry %%SITE_PERL%%/CSS