aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Data-FormValidator-Constraints-DateTime
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2007-08-16 21:58:13 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2007-08-16 21:58:13 +0000
commit09c157329718dddea5aad8d202e5a748e8fb8340 (patch)
tree5e8ef21e245b97b61a36717a2b55a283b4fb6e70 /textproc/p5-Data-FormValidator-Constraints-DateTime
parent0a8c2bf69fbec6a2c410d360dfd958b44b60a1d9 (diff)
downloadports-09c157329718dddea5aad8d202e5a748e8fb8340.tar.gz
ports-09c157329718dddea5aad8d202e5a748e8fb8340.zip
Add p5-Data-FormValidator-Constraints-DateTime 1.09, data::FormValidator
constraints for dates and times.
Notes
Notes: svn path=/head/; revision=197822
Diffstat (limited to 'textproc/p5-Data-FormValidator-Constraints-DateTime')
-rw-r--r--textproc/p5-Data-FormValidator-Constraints-DateTime/Makefile28
-rw-r--r--textproc/p5-Data-FormValidator-Constraints-DateTime/distinfo3
-rw-r--r--textproc/p5-Data-FormValidator-Constraints-DateTime/pkg-descr8
-rw-r--r--textproc/p5-Data-FormValidator-Constraints-DateTime/pkg-plist4
4 files changed, 43 insertions, 0 deletions
diff --git a/textproc/p5-Data-FormValidator-Constraints-DateTime/Makefile b/textproc/p5-Data-FormValidator-Constraints-DateTime/Makefile
new file mode 100644
index 000000000000..99afe86c6361
--- /dev/null
+++ b/textproc/p5-Data-FormValidator-Constraints-DateTime/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Data-FormValidator-Constraints-DateTime
+# Date created: 17 August 2007
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-FormValidator-Constraints-DateTime
+PORTVERSION= 1.09
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/W/WO/WONKO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Data::FormValidator constraints for dates and times
+
+BUILD_DEPENDS= ${SITE_PERL}/Data/FormValidator.pm:${PORTSDIR}/textproc/p5-Data-FormValidator \
+ ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
+ ${SITE_PERL}/DateTime/Format/Strptime.pm:${PORTSDIR}/devel/p5-DateTime-Format-Strptime \
+ ${SITE_PERL}/DateTime/Format/Builder.pm:${PORTSDIR}/devel/p5-DateTime-Format-Builder
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Data::FormValidator::Constraints::DateTime.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Data-FormValidator-Constraints-DateTime/distinfo b/textproc/p5-Data-FormValidator-Constraints-DateTime/distinfo
new file mode 100644
index 000000000000..1518cf352ae8
--- /dev/null
+++ b/textproc/p5-Data-FormValidator-Constraints-DateTime/distinfo
@@ -0,0 +1,3 @@
+MD5 (Data-FormValidator-Constraints-DateTime-1.09.tar.gz) = adec700adf05d817e09e890d99d9a339
+SHA256 (Data-FormValidator-Constraints-DateTime-1.09.tar.gz) = e23b06227f54d2f6c5d5825572df1f3942c44d3a0cf5a8d1e31262efce1cea7e
+SIZE (Data-FormValidator-Constraints-DateTime-1.09.tar.gz) = 12550
diff --git a/textproc/p5-Data-FormValidator-Constraints-DateTime/pkg-descr b/textproc/p5-Data-FormValidator-Constraints-DateTime/pkg-descr
new file mode 100644
index 000000000000..141237d2b8e7
--- /dev/null
+++ b/textproc/p5-Data-FormValidator-Constraints-DateTime/pkg-descr
@@ -0,0 +1,8 @@
+This package provides constraint routines for Data::FormValidator for
+dealing with dates and times. It provides an easy mechanism for
+validating dates of any format (using strptime(3)) and transforming
+those dates (as long as you 'untaint' the fields) into valid DateTime
+objects, or into strings that would be properly formatted for various
+database engines.
+
+WWW: http://search.cpan.org/dist/Data-FormValidator-Constraints-DateTime/
diff --git a/textproc/p5-Data-FormValidator-Constraints-DateTime/pkg-plist b/textproc/p5-Data-FormValidator-Constraints-DateTime/pkg-plist
new file mode 100644
index 000000000000..db60c38c1ad6
--- /dev/null
+++ b/textproc/p5-Data-FormValidator-Constraints-DateTime/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Data/FormValidator/Constraints/DateTime.pm
+@dirrmtry %%SITE_PERL%%/Data/FormValidator/Constraints
+@dirrmtry %%SITE_PERL%%/Data/FormValidator
+@dirrmtry %%SITE_PERL%%/Data