aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Getopt-Lucid
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-02-19 06:55:03 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-02-19 06:55:03 +0000
commit534294fdd9ae63d9b0b420827070a16c98ac041e (patch)
tree269cfb92110f3ed0c889a6772b0852481bd68e9f /textproc/p5-Getopt-Lucid
parentcaa49233e40bdf500b68e560eba20197f3439d0b (diff)
downloadports-534294fdd9ae63d9b0b420827070a16c98ac041e.tar.gz
ports-534294fdd9ae63d9b0b420827070a16c98ac041e.zip
The goal of this module is providing good code readability and clarity
of intent for command-line option processing. While readability is a subjective standard, Getopt::Lucid relies on a more verbose, plain-English option specification as compared against the more symbolic approach of Getopt::Long. WWW: http://search.cpan.org/dist/Getopt-Lucid/ PR: ports/120804 Submitted by: Felippe de Meirelles Motta <lippemail at gmail.com>
Notes
Notes: svn path=/head/; revision=207572
Diffstat (limited to 'textproc/p5-Getopt-Lucid')
-rw-r--r--textproc/p5-Getopt-Lucid/Makefile28
-rw-r--r--textproc/p5-Getopt-Lucid/distinfo3
-rw-r--r--textproc/p5-Getopt-Lucid/pkg-descr7
-rw-r--r--textproc/p5-Getopt-Lucid/pkg-plist8
4 files changed, 46 insertions, 0 deletions
diff --git a/textproc/p5-Getopt-Lucid/Makefile b/textproc/p5-Getopt-Lucid/Makefile
new file mode 100644
index 000000000000..ed5e3c2964af
--- /dev/null
+++ b/textproc/p5-Getopt-Lucid/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Getopt-Lucid
+# Date created: 2008-02-14
+# Whom: Felippe de Meirelles Motta <lippemail@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Getopt-Lucid
+PORTVERSION= 0.16
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lippemail@gmail.com
+COMMENT= Getopt::Lucid - Clear, readable syntax for command line processing
+
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Data/Dumper.pm:${PORTSDIR}/devel/p5-Data-Dumper \
+ ${SITE_PERL}/Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Class \
+ ${SITE_PERL}/Exception/Class/TryCatch.pm:${PORTSDIR}/devel/p5-Exception-Class-TryCatch \
+ ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
+ ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Getopt::Lucid.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Getopt-Lucid/distinfo b/textproc/p5-Getopt-Lucid/distinfo
new file mode 100644
index 000000000000..0d99e4f77c56
--- /dev/null
+++ b/textproc/p5-Getopt-Lucid/distinfo
@@ -0,0 +1,3 @@
+MD5 (Getopt-Lucid-0.16.tar.gz) = e09eee84dc5dcaf25713dc7e5b574dcd
+SHA256 (Getopt-Lucid-0.16.tar.gz) = 6da381bc18b471a4c7c155a95612f1433ddd636f088298f9db9b9c0bfea3c35c
+SIZE (Getopt-Lucid-0.16.tar.gz) = 40362
diff --git a/textproc/p5-Getopt-Lucid/pkg-descr b/textproc/p5-Getopt-Lucid/pkg-descr
new file mode 100644
index 000000000000..9cac27a1f00f
--- /dev/null
+++ b/textproc/p5-Getopt-Lucid/pkg-descr
@@ -0,0 +1,7 @@
+The goal of this module is providing good code readability and clarity
+of intent for command-line option processing. While readability is a
+subjective standard, Getopt::Lucid relies on a more verbose,
+plain-English option specification as compared against the more symbolic
+approach of Getopt::Long.
+
+WWW: http://search.cpan.org/dist/Getopt-Lucid/
diff --git a/textproc/p5-Getopt-Lucid/pkg-plist b/textproc/p5-Getopt-Lucid/pkg-plist
new file mode 100644
index 000000000000..ad8d347e098a
--- /dev/null
+++ b/textproc/p5-Getopt-Lucid/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Getopt/Lucid/.packlist
+%%SITE_PERL%%/Getopt/Lucid.pm
+%%SITE_PERL%%/Getopt/Lucid/Exception.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Getopt/Lucid
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Getopt
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto
+@dirrmtry %%SITE_PERL%%/Getopt/Lucid
+@dirrmtry %%SITE_PERL%%/Getopt