aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-HTML-EscapeEvil
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2006-02-14 08:28:35 +0000
committerAnton Berezin <tobez@FreeBSD.org>2006-02-14 08:28:35 +0000
commitdcfa97dfcdb68e4e775423d8873d24f63fbef3ff (patch)
tree2d77ea449f8acca59ef4591d086cce4e1a8cb711 /textproc/p5-HTML-EscapeEvil
parentc2141463bbbc00fd41fc1c26d7a5b127521113a3 (diff)
downloadports-dcfa97dfcdb68e4e775423d8873d24f63fbef3ff.tar.gz
ports-dcfa97dfcdb68e4e775423d8873d24f63fbef3ff.zip
Add textproc/p5-HTML-EscapeEvil, a Perl module that will escape HTML
tags considered evil.
Notes
Notes: svn path=/head/; revision=155983
Diffstat (limited to 'textproc/p5-HTML-EscapeEvil')
-rw-r--r--textproc/p5-HTML-EscapeEvil/Makefile33
-rw-r--r--textproc/p5-HTML-EscapeEvil/distinfo3
-rw-r--r--textproc/p5-HTML-EscapeEvil/pkg-descr5
-rw-r--r--textproc/p5-HTML-EscapeEvil/pkg-plist5
4 files changed, 46 insertions, 0 deletions
diff --git a/textproc/p5-HTML-EscapeEvil/Makefile b/textproc/p5-HTML-EscapeEvil/Makefile
new file mode 100644
index 000000000000..d920a6b9f7c6
--- /dev/null
+++ b/textproc/p5-HTML-EscapeEvil/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: textproc/p5-HTML-EscapeEvil
+# Date created: 13 February 2006
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-EscapeEvil
+PORTVERSION= 0.03
+CATEGORIES= textproc perl5 www
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= HTML::EscapeEvil - escape evil HTML tags
+
+BUILD_DEPENDS= ${SITE_PERL}/HTML/Element.pm:${PORTSDIR}/www/p5-HTML-Tree \
+ ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
+ ${SITE_PERL}/${PERL_ARCH}/HTML/Filter.pm:${PORTSDIR}/www/p5-HTML-Parser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= HTML::EscapeEvil.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-HTML-EscapeEvil/distinfo b/textproc/p5-HTML-EscapeEvil/distinfo
new file mode 100644
index 000000000000..dbf169e1a57b
--- /dev/null
+++ b/textproc/p5-HTML-EscapeEvil/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTML-EscapeEvil-0.03.tar.gz) = e2b8932aaa4096745378920fda228937
+SHA256 (HTML-EscapeEvil-0.03.tar.gz) = dd777be088986a12d04455a74e636dfccb8f37207ca685b0a065e86625be612d
+SIZE (HTML-EscapeEvil-0.03.tar.gz) = 6846
diff --git a/textproc/p5-HTML-EscapeEvil/pkg-descr b/textproc/p5-HTML-EscapeEvil/pkg-descr
new file mode 100644
index 000000000000..c444d6c6bcc6
--- /dev/null
+++ b/textproc/p5-HTML-EscapeEvil/pkg-descr
@@ -0,0 +1,5 @@
+HTML::EscapeEvil is a Perl module that will escape HTML tags considered
+evil (useful for user inut filtering). It is somewhat similar to
+HTML::TagFilter, but escapes tags instead of removing them.
+
+WWW: http://search.cpan.org/dist/HTML-EscapeEvil/
diff --git a/textproc/p5-HTML-EscapeEvil/pkg-plist b/textproc/p5-HTML-EscapeEvil/pkg-plist
new file mode 100644
index 000000000000..88276a6ffbb5
--- /dev/null
+++ b/textproc/p5-HTML-EscapeEvil/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/HTML/EscapeEvil.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/EscapeEvil/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/EscapeEvil
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML
+@dirrmtry %%SITE_PERL%%/HTML