aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-HTML-TagFilter
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-11-06 20:44:52 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-11-06 20:44:52 +0000
commit7e8ad40fdf4a7de1331f5b8f0d1a52189ae3505e (patch)
treee2be88ca250a35bb55775f1563196509960045c4 /textproc/p5-HTML-TagFilter
parentc56948c748fd7db6cc5fa67ef0a56cfe98a62574 (diff)
downloadports-7e8ad40fdf4a7de1331f5b8f0d1a52189ae3505e.tar.gz
ports-7e8ad40fdf4a7de1331f5b8f0d1a52189ae3505e.zip
Add textproc/p5-HTML-TagFilter 1.01, a fine-grained html-filter,
xss-blocker and mailto-obfuscator.
Notes
Notes: svn path=/head/; revision=147459
Diffstat (limited to 'textproc/p5-HTML-TagFilter')
-rw-r--r--textproc/p5-HTML-TagFilter/Makefile26
-rw-r--r--textproc/p5-HTML-TagFilter/distinfo2
-rw-r--r--textproc/p5-HTML-TagFilter/pkg-descr7
-rw-r--r--textproc/p5-HTML-TagFilter/pkg-plist5
4 files changed, 40 insertions, 0 deletions
diff --git a/textproc/p5-HTML-TagFilter/Makefile b/textproc/p5-HTML-TagFilter/Makefile
new file mode 100644
index 000000000000..314ecbbcc844
--- /dev/null
+++ b/textproc/p5-HTML-TagFilter/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: textproc/p5-HTML-TagFilter
+# Date created: 06 November 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-TagFilter
+PORTVERSION= 1.01
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= A fine-grained html-filter, xss-blocker and mailto-obfuscator
+
+BUILD_DEPENDS= ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= HTML::TagFilter.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-HTML-TagFilter/distinfo b/textproc/p5-HTML-TagFilter/distinfo
new file mode 100644
index 000000000000..4bc52a21e7fb
--- /dev/null
+++ b/textproc/p5-HTML-TagFilter/distinfo
@@ -0,0 +1,2 @@
+MD5 (HTML-TagFilter-1.01.tar.gz) = 1fe4f59af3737093a908643dad493a4a
+SIZE (HTML-TagFilter-1.01.tar.gz) = 15284
diff --git a/textproc/p5-HTML-TagFilter/pkg-descr b/textproc/p5-HTML-TagFilter/pkg-descr
new file mode 100644
index 000000000000..5eae6690ef8a
--- /dev/null
+++ b/textproc/p5-HTML-TagFilter/pkg-descr
@@ -0,0 +1,7 @@
+HTML::TagFilter is a subclass of HTML::Parser with a single purpose: it
+will remove unwanted html tags and attributes from a piece of text. It
+can act in a more or less fine-grained way - you can specify permitted
+tags, permitted attributes of each tag, and permitted values for each
+attribute in as much detail as you like.
+
+WWW: http://search.cpan.org/dist/HTML-TagFilter/
diff --git a/textproc/p5-HTML-TagFilter/pkg-plist b/textproc/p5-HTML-TagFilter/pkg-plist
new file mode 100644
index 000000000000..2a3f9b323803
--- /dev/null
+++ b/textproc/p5-HTML-TagFilter/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/HTML/TagFilter.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/TagFilter/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/TagFilter 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/HTML 2>/dev/null || true