aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Lingua-EN-MatchNames/Makefile
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-06-08 22:33:42 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-06-08 22:33:42 +0000
commit330c9e4d7391069b3473df507418f5b2e874d41a (patch)
treecf7c1407d9b3af53e45f54f5d80d354b077b2bdc /textproc/p5-Lingua-EN-MatchNames/Makefile
parent02e74a11f278bda4249040bf6fefdad66e524791 (diff)
downloadports-330c9e4d7391069b3473df507418f5b2e874d41a.tar.gz
ports-330c9e4d7391069b3473df507418f5b2e874d41a.zip
Add p5-Lingua-EN-MatchNames 1.1, smart matching for human names.
PR: 33379 Submitted by: Seamus Venasse <svenasse@polaris.ca>
Notes
Notes: svn path=/head/; revision=60916
Diffstat (limited to 'textproc/p5-Lingua-EN-MatchNames/Makefile')
-rw-r--r--textproc/p5-Lingua-EN-MatchNames/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/textproc/p5-Lingua-EN-MatchNames/Makefile b/textproc/p5-Lingua-EN-MatchNames/Makefile
new file mode 100644
index 000000000000..11c17f59349f
--- /dev/null
+++ b/textproc/p5-Lingua-EN-MatchNames/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: Lingua::EN::MatchNames
+# Date created: 30 Dec 2001
+# Whom: Seamus Venasse <svenasse@polaris.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Lingua-EN-MatchNames
+PORTVERSION= 1.1
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Lingua
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svenasse@polaris.ca
+
+BUILD_DEPENDS= ${SITE_PERL}/Lingua/EN/NameParse.pm:${PORTSDIR}/textproc/p5-Lingua-EN-NameParse \
+ ${SITE_PERL}/Lingua/EN/Nickname.pm:${PORTSDIR}/textproc/p5-Lingua-EN-Nickname \
+ ${SITE_PERL}/${PERL_ARCH}/String/Approx.pm:${PORTSDIR}/devel/p5-String-Approx \
+ ${SITE_PERL}/${PERL_ARCH}/Text/Metaphone.pm:${PORTSDIR}/textproc/p5-Text-Metaphone
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+SITE_PERL= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
+PERL_CONFIGURE= yes
+
+MAN3= Lingua::EN::MatchNames.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>