aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-MKDoc-XML/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-25 22:55:23 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-25 22:55:23 +0000
commit21d57492ac70cde3589955970d0a96dedc651daa (patch)
treec2cb8e3c4b8d8a46c960e5fdfabd54081e587c1b /textproc/p5-MKDoc-XML/Makefile
parent60fc88b53594629e4e0073de765f9801c811d9b9 (diff)
downloadports-21d57492ac70cde3589955970d0a96dedc651daa.tar.gz
ports-21d57492ac70cde3589955970d0a96dedc651daa.zip
Adding port textproc/p5-MKDoc-XML, The MKDoc XML Toolkit.
Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=163435
Diffstat (limited to 'textproc/p5-MKDoc-XML/Makefile')
-rw-r--r--textproc/p5-MKDoc-XML/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/textproc/p5-MKDoc-XML/Makefile b/textproc/p5-MKDoc-XML/Makefile
new file mode 100644
index 000000000000..9f840aa0b5ce
--- /dev/null
+++ b/textproc/p5-MKDoc-XML/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: p5-MKDoc-XML
+# Date created: 25 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MKDoc-XML
+PORTVERSION= 0.75
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/B/BP/BPOSTLE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= The MKDoc XML Toolkit
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= MKDoc::XML.3 \
+ MKDoc::XML::Decode.3 \
+ MKDoc::XML::Dumper.3 \
+ MKDoc::XML::Encode.3 \
+ MKDoc::XML::Stripper.3 \
+ MKDoc::XML::Tagger.3 \
+ MKDoc::XML::Token.3 \
+ MKDoc::XML::Tokenizer.3 \
+ MKDoc::XML::TreeBuilder.3 \
+ MKDoc::XML::TreePrinter.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>