aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-POSIX-Regex
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-09-26 08:18:26 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-09-26 08:18:26 +0000
commit6a772478f0c4490e27c585bbca74fbaa53e32074 (patch)
tree766ae5ba6d4f738e20f10afba3aa4d781780df31 /textproc/p5-POSIX-Regex
parent2fbadb7a40b7d6f9c5045df5b484fe61f6c92d6c (diff)
downloadports-6a772478f0c4490e27c585bbca74fbaa53e32074.tar.gz
ports-6a772478f0c4490e27c585bbca74fbaa53e32074.zip
Add p5-POSIX-Regex 0.89, OO interface for the gnu regex engine.
PR: ports/102253 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=173867
Diffstat (limited to 'textproc/p5-POSIX-Regex')
-rw-r--r--textproc/p5-POSIX-Regex/Makefile36
-rw-r--r--textproc/p5-POSIX-Regex/distinfo3
-rw-r--r--textproc/p5-POSIX-Regex/pkg-descr12
-rw-r--r--textproc/p5-POSIX-Regex/pkg-plist9
4 files changed, 60 insertions, 0 deletions
diff --git a/textproc/p5-POSIX-Regex/Makefile b/textproc/p5-POSIX-Regex/Makefile
new file mode 100644
index 000000000000..49a1ba235b3c
--- /dev/null
+++ b/textproc/p5-POSIX-Regex/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: p5-POSIX-Regex
+# Date created: 2006-08-19
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POSIX-Regex
+PORTVERSION= 0.89
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POSIX
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= OO interface for the gnu regex engine
+
+PERL_CONFIGURE= yes
+USE_GCC= 3.2+
+
+MAN3= POSIX::Regex.3
+
+post-patch:
+ ${PERL} -pi -e 's/REG_NOERROR/0/g' ${WRKSRC}/Regex.xs
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+BUILD_DEPENDS+= ${SITE_PERL}/ExtUtils/Constant.pm:${PORTSDIR}/devel/p5-ExtUtils-Constant
+.endif
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-POSIX-Regex/distinfo b/textproc/p5-POSIX-Regex/distinfo
new file mode 100644
index 000000000000..b6fb7efcb2bd
--- /dev/null
+++ b/textproc/p5-POSIX-Regex/distinfo
@@ -0,0 +1,3 @@
+MD5 (POSIX-Regex-0.89.tar.gz) = 0b37034a809231c4581476339fa32c39
+SHA256 (POSIX-Regex-0.89.tar.gz) = 08e253fe0c9ac3b5be5f85454e51fd64fad6a21f15b258385bbfd5878794a579
+SIZE (POSIX-Regex-0.89.tar.gz) = 5001
diff --git a/textproc/p5-POSIX-Regex/pkg-descr b/textproc/p5-POSIX-Regex/pkg-descr
new file mode 100644
index 000000000000..ea7f000ff351
--- /dev/null
+++ b/textproc/p5-POSIX-Regex/pkg-descr
@@ -0,0 +1,12 @@
+This is a port of the glibc gnu regex engine into perl. There are few
+reasons you would need this. The few I can think of include:
+
+0) You wish to use untrusted user expressions in such a way as to be
+able to catch errors. Example: eval { alarm 2; m/((){1024}){1024}/ }
+is an instant uncatchable segmentation fault. GNU's regexps will still
+fail, but in a timeout way rather than an instant segfault way.
+
+1) You wish to have POSIX compliance on ... something ... Perl's
+regexps are slightly different -- arguably better, but different.
+
+WWW: http://search.cpan.org/dist/POSIX-Regex/
diff --git a/textproc/p5-POSIX-Regex/pkg-plist b/textproc/p5-POSIX-Regex/pkg-plist
new file mode 100644
index 000000000000..4e051a646e24
--- /dev/null
+++ b/textproc/p5-POSIX-Regex/pkg-plist
@@ -0,0 +1,9 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/POSIX/Regex.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POSIX/Regex/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POSIX/Regex/Regex.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POSIX/Regex/Regex.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POSIX/Regex/autosplit.ix
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POSIX/Regex
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POSIX
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/POSIX