aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-PPIx-EditorTools
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-07-15 13:47:55 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-07-15 13:47:55 +0000
commit02cd8b6e648c25baa6e7161675ba609e5baed3f6 (patch)
treec2e7e026d5ad3f2799ecf88b21e47f2e37f901e9 /textproc/p5-PPIx-EditorTools
parentd4ab668367056ff7eff0a7ea564ac5c812fde872 (diff)
downloadports-02cd8b6e648c25baa6e7161675ba609e5baed3f6.tar.gz
ports-02cd8b6e648c25baa6e7161675ba609e5baed3f6.zip
Base class and utility methods for manipulating Perl via PPI. Pulled
out from the Padre::Task::PPI code. WWW: http://search.cpan.org/dist/PPIx-EditorTools/ PR: 136699 Submitted by: Cezary Morga <cm@therek.net>
Notes
Notes: svn path=/head/; revision=237878
Diffstat (limited to 'textproc/p5-PPIx-EditorTools')
-rw-r--r--textproc/p5-PPIx-EditorTools/Makefile33
-rw-r--r--textproc/p5-PPIx-EditorTools/distinfo3
-rw-r--r--textproc/p5-PPIx-EditorTools/pkg-descr4
-rw-r--r--textproc/p5-PPIx-EditorTools/pkg-plist13
4 files changed, 53 insertions, 0 deletions
diff --git a/textproc/p5-PPIx-EditorTools/Makefile b/textproc/p5-PPIx-EditorTools/Makefile
new file mode 100644
index 000000000000..72203b7b4e6d
--- /dev/null
+++ b/textproc/p5-PPIx-EditorTools/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-PPIx-EditorTools
+# Date created: July 12th 2009
+# Whom: Cezary Morga <cm@therek.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= PPIx-EditorTools
+PORTVERSION= 0.06
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/R/RS/RSN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= cm@therek.net
+COMMENT= Utility methods and base class for manipulating Perl via PPI
+
+BUILD_DEPENDS= p5-Class-XSAccessor>=1.02:${PORTSDIR}/devel/p5-Class-XSAccessor \
+ p5-PPI>=1.203:${PORTSDIR}/textproc/p5-PPI
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= 5.8.0+
+
+MAN3= PPIx::EditorTools::RenamePackage.3 \
+ PPIx::EditorTools::RenamePackageFromPath.3 \
+ PPIx::EditorTools::ReturnObject.3 \
+ PPIx::EditorTools::FindVariableDeclaration.3 \
+ PPIx::EditorTools::IntroduceTemporaryVariable.3 \
+ PPIx::EditorTools::RenameVariable.3 \
+ PPIx::EditorTools.3 \
+ PPIx::EditorTools::FindUnmatchedBrace.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-PPIx-EditorTools/distinfo b/textproc/p5-PPIx-EditorTools/distinfo
new file mode 100644
index 000000000000..e78a24e76418
--- /dev/null
+++ b/textproc/p5-PPIx-EditorTools/distinfo
@@ -0,0 +1,3 @@
+MD5 (PPIx-EditorTools-0.06.tar.gz) = 6177477172939831c617de69c5e0cd6f
+SHA256 (PPIx-EditorTools-0.06.tar.gz) = 2021b622f6c6c118de8ee8a15d2039d94fe005b14195b764c341bfea811f736f
+SIZE (PPIx-EditorTools-0.06.tar.gz) = 26347
diff --git a/textproc/p5-PPIx-EditorTools/pkg-descr b/textproc/p5-PPIx-EditorTools/pkg-descr
new file mode 100644
index 000000000000..11546aaa2767
--- /dev/null
+++ b/textproc/p5-PPIx-EditorTools/pkg-descr
@@ -0,0 +1,4 @@
+Base class and utility methods for manipulating Perl via PPI. Pulled
+out from the Padre::Task::PPI code.
+
+WWW: http://search.cpan.org/dist/PPIx-EditorTools/
diff --git a/textproc/p5-PPIx-EditorTools/pkg-plist b/textproc/p5-PPIx-EditorTools/pkg-plist
new file mode 100644
index 000000000000..4d3d737e29ca
--- /dev/null
+++ b/textproc/p5-PPIx-EditorTools/pkg-plist
@@ -0,0 +1,13 @@
+%%SITE_PERL%%/PPIx/EditorTools/FindUnmatchedBrace.pm
+%%SITE_PERL%%/PPIx/EditorTools/IntroduceTemporaryVariable.pm
+%%SITE_PERL%%/PPIx/EditorTools/RenamePackage.pm
+%%SITE_PERL%%/PPIx/EditorTools/ReturnObject.pm
+%%SITE_PERL%%/PPIx/EditorTools/RenamePackageFromPath.pm
+%%SITE_PERL%%/PPIx/EditorTools/RenameVariable.pm
+%%SITE_PERL%%/PPIx/EditorTools/FindVariableDeclaration.pm
+%%SITE_PERL%%/PPIx/EditorTools.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/PPIx/EditorTools/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/PPIx/EditorTools
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/PPIx
+@dirrmtry %%SITE_PERL%%/PPIx/EditorTools
+@dirrmtry %%SITE_PERL%%/PPIx