aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Parse-BooleanLogic
diff options
context:
space:
mode:
authorSteven Kreuzer <skreuzer@FreeBSD.org>2009-11-24 14:51:07 +0000
committerSteven Kreuzer <skreuzer@FreeBSD.org>2009-11-24 14:51:07 +0000
commit404637ffaf3864a84b3520c594a3e9404bfdc754 (patch)
tree2d2c107cbff2d6e3d93721ead332e4efedce5b6c /textproc/p5-Parse-BooleanLogic
parentb9c38e0d18a2724fe2c01d59fbefe15f34b377b5 (diff)
Notes
Diffstat (limited to 'textproc/p5-Parse-BooleanLogic')
-rw-r--r--textproc/p5-Parse-BooleanLogic/Makefile25
-rw-r--r--textproc/p5-Parse-BooleanLogic/distinfo3
-rw-r--r--textproc/p5-Parse-BooleanLogic/pkg-descr6
-rw-r--r--textproc/p5-Parse-BooleanLogic/pkg-plist6
4 files changed, 40 insertions, 0 deletions
diff --git a/textproc/p5-Parse-BooleanLogic/Makefile b/textproc/p5-Parse-BooleanLogic/Makefile
new file mode 100644
index 000000000000..53229f1855e9
--- /dev/null
+++ b/textproc/p5-Parse-BooleanLogic/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Parse-BooleanLogic
+# Date created: 2009-11-23
+# Whom: Steven Kreuzer <skreuzer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Parse-BooleanLogic
+PORTVERSION= 0.09
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skreuzer@FreeBSD.org
+COMMENT= Parser of boolean expressions
+
+BUILD_DEPENDS= p5-Regexp-Common>=2.122:${PORTSDIR}/textproc/p5-Regexp-Common \
+ p5-Module-Install>=0.91_1:${PORTSDIR}/devel/p5-Module-Install
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Parse::BooleanLogic.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Parse-BooleanLogic/distinfo b/textproc/p5-Parse-BooleanLogic/distinfo
new file mode 100644
index 000000000000..ab30dc8b6480
--- /dev/null
+++ b/textproc/p5-Parse-BooleanLogic/distinfo
@@ -0,0 +1,3 @@
+MD5 (Parse-BooleanLogic-0.09.tar.gz) = 3defed0f2fa9845525c2de4b1e65955d
+SHA256 (Parse-BooleanLogic-0.09.tar.gz) = f52701f51ef29f65ddcd9f68634ac9cec1fbc6fb6c97b2f5c47ac1e5347b4ae6
+SIZE (Parse-BooleanLogic-0.09.tar.gz) = 21585
diff --git a/textproc/p5-Parse-BooleanLogic/pkg-descr b/textproc/p5-Parse-BooleanLogic/pkg-descr
new file mode 100644
index 000000000000..b652ae6bc3bc
--- /dev/null
+++ b/textproc/p5-Parse-BooleanLogic/pkg-descr
@@ -0,0 +1,6 @@
+Parse::BooleanLogic is a fast parser for boolean expressions. Originally
+written for Request Tracker to parse SQL like expressions, it can be
+used to parse other boolean logic sentences with OPERANDs joined using
+binary OPERATORs and grouped and nested using parentheses.
+
+WWW: http://search.cpan.org/~ruz/Parse-BooleanLogic/
diff --git a/textproc/p5-Parse-BooleanLogic/pkg-plist b/textproc/p5-Parse-BooleanLogic/pkg-plist
new file mode 100644
index 000000000000..f2b3db106492
--- /dev/null
+++ b/textproc/p5-Parse-BooleanLogic/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Parse/BooleanLogic.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse/BooleanLogic/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse/BooleanLogic
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse
+@dirrmtry %%SITE_PERL%%/Parse