aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Perl-Critic
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-26 13:08:24 +0000
commiteee58d187e2c55fca6f53b9e482d33cf5346fe81 (patch)
tree0d350fe6ad6a2fe3222d838f3c72856c78cd449f /textproc/p5-Perl-Critic
parent3f1df82a16a1e89db9a69b36ade7342f34095ab4 (diff)
downloadports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.tar.gz
ports-eee58d187e2c55fca6f53b9e482d33cf5346fe81.zip
Change the way Perl modules are installed, update the default Perl to 5.18.
Before, we had: site_perl : lib/perl5/site_perl/5.18 site_perl/perl_arch : lib/perl5/site_perl/5.18/mach perl_man3 : lib/perl5/5.18/man/man3 Now we have: site_perl : lib/perl5/site_perl site_arch : lib/perl5/site_perl/mach/5.18 perl_man3 : lib/perl5/site_perl/man/man3 Modules without any .so will be installed at the same place regardless of the Perl version, minimizing the upgrade when the major Perl version is changed. It uses a version dependent directory for modules with compiled bits. As PERL_ARCH is no longer needed in plists, it has been removed from PLIST_SUB. The USE_PERL5=fixpacklist keyword is removed, the .packlist file is now always removed, as is perllocal.pod. The old site_perl and site_perl/arch directories have been kept in the default Perl @INC for all Perl ports, and will be phased out as these old Perl versions expire. PR: 194969 Differential Revision: https://reviews.freebsd.org/D1019 Exp-run by: antoine Reviewed by: perl@ Approved by: portmgr
Notes
Notes: svn path=/head/; revision=373448
Diffstat (limited to 'textproc/p5-Perl-Critic')
-rw-r--r--textproc/p5-Perl-Critic/Makefile1
-rw-r--r--textproc/p5-Perl-Critic/pkg-plist33
2 files changed, 1 insertions, 33 deletions
diff --git a/textproc/p5-Perl-Critic/Makefile b/textproc/p5-Perl-Critic/Makefile
index 352556487a23..89d15f72c883 100644
--- a/textproc/p5-Perl-Critic/Makefile
+++ b/textproc/p5-Perl-Critic/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Perl-Critic
PORTVERSION= 1.12.1
+PORTREVISION= 1
CATEGORIES= textproc devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
diff --git a/textproc/p5-Perl-Critic/pkg-plist b/textproc/p5-Perl-Critic/pkg-plist
index 297301eb0d32..c5dfed9de682 100644
--- a/textproc/p5-Perl-Critic/pkg-plist
+++ b/textproc/p5-Perl-Critic/pkg-plist
@@ -390,36 +390,3 @@ bin/perlcritic
%%PERL5_MAN3%%/Perl::Critic::Violation.3.gz
%%PERL5_MAN3%%/Test::Perl::Critic::Policy.3.gz
man/man1/perlcritic.1.gz
-@dirrmtry %%SITE_PERL%%/Test/Perl/Critic
-@dirrmtry %%SITE_PERL%%/Test/Perl
-@dirrmtry %%SITE_PERL%%/Test
-@dirrmtry %%SITE_PERL%%/Perl/Critic/Utils/POD
-@dirrmtry %%SITE_PERL%%/Perl/Critic/Utils
-@dirrmtry %%SITE_PERL%%/Perl/Critic/PolicyParameter/Behavior
-@dirrmtry %%SITE_PERL%%/Perl/Critic/PolicyParameter
-@dirrmtry %%SITE_PERL%%/Perl/Critic/Policy/Variables
-@dirrmtry %%SITE_PERL%%/Perl/Critic/Policy/ValuesAndExpressions
-@dirrmtry %%SITE_PERL%%/Perl/Critic/Policy/TestingAndDebugging
-@dirrmtry %%SITE_PERL%%/Perl/Critic/Policy/Subroutines
-@dirrmtry %%SITE_PERL%%/Perl/Critic/Policy/RegularExpressions
-@dirrmtry %%SITE_PERL%%/Perl/Critic/Policy/References
-@dirrmtry %%SITE_PERL%%/Perl/Critic/Policy/Objects
-@dirrmtry %%SITE_PERL%%/Perl/Critic/Policy/NamingConventions
-@dirrmtry %%SITE_PERL%%/Perl/Critic/Policy/Modules
-@dirrmtry %%SITE_PERL%%/Perl/Critic/Policy/Miscellanea
-@dirrmtry %%SITE_PERL%%/Perl/Critic/Policy/InputOutput
-@dirrmtry %%SITE_PERL%%/Perl/Critic/Policy/ErrorHandling
-@dirrmtry %%SITE_PERL%%/Perl/Critic/Policy/Documentation
-@dirrmtry %%SITE_PERL%%/Perl/Critic/Policy/ControlStructures
-@dirrmtry %%SITE_PERL%%/Perl/Critic/Policy/CodeLayout
-@dirrmtry %%SITE_PERL%%/Perl/Critic/Policy/ClassHierarchies
-@dirrmtry %%SITE_PERL%%/Perl/Critic/Policy/BuiltinFunctions
-@dirrmtry %%SITE_PERL%%/Perl/Critic/Policy
-@dirrmtry %%SITE_PERL%%/Perl/Critic/Exception/Fatal
-@dirrmtry %%SITE_PERL%%/Perl/Critic/Exception/Configuration/Option/Policy
-@dirrmtry %%SITE_PERL%%/Perl/Critic/Exception/Configuration/Option/Global
-@dirrmtry %%SITE_PERL%%/Perl/Critic/Exception/Configuration/Option
-@dirrmtry %%SITE_PERL%%/Perl/Critic/Exception/Configuration
-@dirrmtry %%SITE_PERL%%/Perl/Critic/Exception
-@dirrmtry %%SITE_PERL%%/Perl/Critic
-@dirrmtry %%SITE_PERL%%/Perl