aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Perl-Lint
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-04-05 15:55:38 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2015-04-05 15:55:38 +0000
commitfb207b62ab6c555ca91f4f53ba2f08a821a39e97 (patch)
tree9dcf1bead41d0ed5b1dd80fc60ed8bd9c403eac1 /textproc/p5-Perl-Lint
parent931a5f89210eb8730cb7ad8969ae3e0385f5e557 (diff)
downloadports-fb207b62ab6c555ca91f4f53ba2f08a821a39e97.tar.gz
ports-fb207b62ab6c555ca91f4f53ba2f08a821a39e97.zip
Update to 0.22. Add Module::Pluggable for perl >= 5.20.
Donate this port to perl@. Changes: https://metacpan.org/changes/distribution/Perl-Lint
Notes
Notes: svn path=/head/; revision=383301
Diffstat (limited to 'textproc/p5-Perl-Lint')
-rw-r--r--textproc/p5-Perl-Lint/Makefile13
-rw-r--r--textproc/p5-Perl-Lint/distinfo4
-rw-r--r--textproc/p5-Perl-Lint/pkg-plist2
3 files changed, 14 insertions, 5 deletions
diff --git a/textproc/p5-Perl-Lint/Makefile b/textproc/p5-Perl-Lint/Makefile
index a6e5156a6c06..ff1ad0f068a8 100644
--- a/textproc/p5-Perl-Lint/Makefile
+++ b/textproc/p5-Perl-Lint/Makefile
@@ -2,13 +2,13 @@
# $FreeBSD$
PORTNAME= Perl-Lint
-PORTVERSION= 0.21
+PORTVERSION= 0.22
CATEGORIES= textproc perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:MOZNION
PKGNAMEPREFIX= p5-
-MAINTAINER= adamw@FreeBSD.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= Yet another Perl source code linter
BUILD_DEPENDS= p5-B-Keywords>=0:${PORTSDIR}/devel/p5-B-Keywords \
@@ -16,6 +16,7 @@ BUILD_DEPENDS= p5-B-Keywords>=0:${PORTSDIR}/devel/p5-B-Keywords \
p5-Email-Address>=0:${PORTSDIR}/mail/p5-Email-Address \
p5-List-Flatten>=0:${PORTSDIR}/devel/p5-List-Flatten \
p5-List-MoreUtils>=0.33:${PORTSDIR}/lang/p5-List-MoreUtils \
+ p5-Path-Tiny>=0.068:${PORTSDIR}/devel/p5-Path-Tiny \
p5-Regexp-Lexer>=0.05:${PORTSDIR}/devel/p5-Regexp-Lexer \
p5-Scalar-List-Utils>=1.41:${PORTSDIR}/lang/p5-Scalar-List-Utils \
p5-String-CamelCase>=0:${PORTSDIR}/textproc/p5-String-CamelCase \
@@ -26,4 +27,10 @@ TEST_DEPENDS= p5-Text-TestBase>=0:${PORTSDIR}/textproc/p5-Text-TestBase
USES= perl5
USE_PERL5= modbuildtiny
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} >= 502000
+TEST_DEPENDS+= p5-Module-Pluggable>=0:${PORTSDIR}/devel/p5-Module-Pluggable
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Perl-Lint/distinfo b/textproc/p5-Perl-Lint/distinfo
index 13f4459b93f2..bb58cb1ce7af 100644
--- a/textproc/p5-Perl-Lint/distinfo
+++ b/textproc/p5-Perl-Lint/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Perl-Lint-0.21.tar.gz) = d64fb992388ba71fe1d00c78aaff21f1f01f21939b195bd04f9625c0050ac400
-SIZE (Perl-Lint-0.21.tar.gz) = 169866
+SHA256 (Perl-Lint-0.22.tar.gz) = 638af616ddea3fc74972f4c8ac4ab78638e74eed7b2db9f10472d8c427cafc11
+SIZE (Perl-Lint-0.22.tar.gz) = 172002
diff --git a/textproc/p5-Perl-Lint/pkg-plist b/textproc/p5-Perl-Lint/pkg-plist
index b949d638b157..818c33a4cc2f 100644
--- a/textproc/p5-Perl-Lint/pkg-plist
+++ b/textproc/p5-Perl-Lint/pkg-plist
@@ -142,6 +142,7 @@
%%SITE_PERL%%/Perl/Lint/Policy/Variables/RequireLexicalLoopIterators.pm
%%SITE_PERL%%/Perl/Lint/Policy/Variables/RequireLocalizedPunctuationVars.pm
%%SITE_PERL%%/Perl/Lint/Policy/Variables/RequireNegativeIndices.pm
+%%SITE_PERL%%/Test/Perl/Lint.pm
%%PERL5_MAN3%%/Perl::Lint.3.gz
%%PERL5_MAN3%%/Perl::Lint::Constants::Kind.3.gz
%%PERL5_MAN3%%/Perl::Lint::Constants::Type.3.gz
@@ -286,3 +287,4 @@
%%PERL5_MAN3%%/Perl::Lint::Policy::Variables::RequireLexicalLoopIterators.3.gz
%%PERL5_MAN3%%/Perl::Lint::Policy::Variables::RequireLocalizedPunctuationVars.3.gz
%%PERL5_MAN3%%/Perl::Lint::Policy::Variables::RequireNegativeIndices.3.gz
+%%PERL5_MAN3%%/Test::Perl::Lint.3.gz