aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Plagger
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2007-10-03 09:40:49 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2007-10-03 09:40:49 +0000
commite06d01e5766321bf87f54163c4234b936c8c4240 (patch)
tree171c95d55158cae5fc11026b89843945204889e3 /textproc/p5-Plagger
parent3cf7896972907b2c0e3483058cb73c079f4e906b (diff)
downloadports-e06d01e5766321bf87f54163c4234b936c8c4240.tar.gz
ports-e06d01e5766321bf87f54163c4234b936c8c4240.zip
Fix enclosure problem with XML::LibXML-1.64.
Notes
Notes: svn path=/head/; revision=200721
Diffstat (limited to 'textproc/p5-Plagger')
-rw-r--r--textproc/p5-Plagger/Makefile1
-rw-r--r--textproc/p5-Plagger/files/patch-lib-Plagger-Plugin-Publish-Feed.pm24
2 files changed, 25 insertions, 0 deletions
diff --git a/textproc/p5-Plagger/Makefile b/textproc/p5-Plagger/Makefile
index 711bea9030d9..d5c72418ff0e 100644
--- a/textproc/p5-Plagger/Makefile
+++ b/textproc/p5-Plagger/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Plagger
PORTVERSION= 0.7.17
+PORTREVISION= 1
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= ../by-authors/id/M/MI/MIYAGAWA
diff --git a/textproc/p5-Plagger/files/patch-lib-Plagger-Plugin-Publish-Feed.pm b/textproc/p5-Plagger/files/patch-lib-Plagger-Plugin-Publish-Feed.pm
new file mode 100644
index 000000000000..d9058a3e5cdd
--- /dev/null
+++ b/textproc/p5-Plagger/files/patch-lib-Plagger-Plugin-Publish-Feed.pm
@@ -0,0 +1,24 @@
+--- lib/Plagger/Plugin/Publish/Feed.pm-
++++ lib/Plagger/Plugin/Publish/Feed.pm
+@@ -148,14 +154,15 @@
+
+ *XML::Feed::Entry::RSS::add_enclosure = sub {
+ my($entry, $enclosure) = @_;
+- $entry->{entry}->{enclosure} = {
+- url => $enclosure->{url},
+- type => $enclosure->{type},
+- length => $enclosure->{length},
+- };
++ $entry->{entry}->{enclosure} = XML::RSS::LibXML::MagicElement->new(
++ attributes => {
++ url => $enclosure->{url},
++ type => $enclosure->{type},
++ length => $enclosure->{length},
++ }
++ );
+ };
+
+-
+ 1;
+
+ __END__