aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Plucene-Plugin-Analyzer-SnowballAnalyzer
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2004-10-14 14:26:26 +0000
committerAnton Berezin <tobez@FreeBSD.org>2004-10-14 14:26:26 +0000
commit9b15174c849b7231b7a9946da4b00aaada065419 (patch)
tree42d434a6f6543076d4481637dd183a1584f3b389 /textproc/p5-Plucene-Plugin-Analyzer-SnowballAnalyzer
parent54c061b3c9460ca5d7cf8744d4396492c0c6072b (diff)
downloadports-9b15174c849b7231b7a9946da4b00aaada065419.tar.gz
ports-9b15174c849b7231b7a9946da4b00aaada065419.zip
Add p5-Plucene-Plugin-Analyzer-SnowballAnalyzer, a stemmed analyzer
plugin for p5-Plucene search engine.
Notes
Notes: svn path=/head/; revision=119417
Diffstat (limited to 'textproc/p5-Plucene-Plugin-Analyzer-SnowballAnalyzer')
-rw-r--r--textproc/p5-Plucene-Plugin-Analyzer-SnowballAnalyzer/Makefile34
-rw-r--r--textproc/p5-Plucene-Plugin-Analyzer-SnowballAnalyzer/distinfo2
-rw-r--r--textproc/p5-Plucene-Plugin-Analyzer-SnowballAnalyzer/pkg-descr4
-rw-r--r--textproc/p5-Plucene-Plugin-Analyzer-SnowballAnalyzer/pkg-plist11
4 files changed, 51 insertions, 0 deletions
diff --git a/textproc/p5-Plucene-Plugin-Analyzer-SnowballAnalyzer/Makefile b/textproc/p5-Plucene-Plugin-Analyzer-SnowballAnalyzer/Makefile
new file mode 100644
index 000000000000..db4f870737b2
--- /dev/null
+++ b/textproc/p5-Plucene-Plugin-Analyzer-SnowballAnalyzer/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: textproc/p5-Plucene-Plugin-Analyzer-SnowballAnalyzer
+# Date created: 14 October 2004
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Plucene-Plugin-Analyzer-SnowballAnalyzer
+PORTVERSION= 1.1
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/F/FA/FABPOT
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Stemmed analyzer plugin for p5-Plucene search engine
+
+BUILD_DEPENDS= ${SITE_PERL}/Lingua/StopWords.pm:${PORTSDIR}/textproc/p5-Lingua-StopWords \
+ ${SITE_PERL}/${PERL_ARCH}/Lingua/Stem/Snowball.pm:${PORTSDIR}/textproc/p5-Lingua-Stem-Snowball \
+ ${SITE_PERL}/Plucene/Analysis/TokenFilter.pm:${PORTSDIR}/textproc/p5-Plucene
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= "This port requires perl 5.6 or newer"
+.endif
+
+MAN3= Plucene::Plugin::Analyzer::SnowballAnalyzer.3 \
+ Plucene::Plugin::Analyzer::SnowballFilter.3
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Plucene-Plugin-Analyzer-SnowballAnalyzer/distinfo b/textproc/p5-Plucene-Plugin-Analyzer-SnowballAnalyzer/distinfo
new file mode 100644
index 000000000000..ae64406c03fc
--- /dev/null
+++ b/textproc/p5-Plucene-Plugin-Analyzer-SnowballAnalyzer/distinfo
@@ -0,0 +1,2 @@
+MD5 (Plucene-Plugin-Analyzer-SnowballAnalyzer-1.1.tar.gz) = b16070333e087af4d7a387b79cb4f8ac
+SIZE (Plucene-Plugin-Analyzer-SnowballAnalyzer-1.1.tar.gz) = 2919
diff --git a/textproc/p5-Plucene-Plugin-Analyzer-SnowballAnalyzer/pkg-descr b/textproc/p5-Plucene-Plugin-Analyzer-SnowballAnalyzer/pkg-descr
new file mode 100644
index 000000000000..15c2dbfdf68c
--- /dev/null
+++ b/textproc/p5-Plucene-Plugin-Analyzer-SnowballAnalyzer/pkg-descr
@@ -0,0 +1,4 @@
+An analyzer plugin for p5-Plucene search engine, which filters
+StandardTokenizer with SnowballAnalyzer.
+
+WWW: http://search.cpan.org/dist/Plucene-Plugin-Analyzer-SnowballAnalyzer
diff --git a/textproc/p5-Plucene-Plugin-Analyzer-SnowballAnalyzer/pkg-plist b/textproc/p5-Plucene-Plugin-Analyzer-SnowballAnalyzer/pkg-plist
new file mode 100644
index 000000000000..3602279b59ff
--- /dev/null
+++ b/textproc/p5-Plucene-Plugin-Analyzer-SnowballAnalyzer/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/Plucene/Plugin/Analyzer/SnowballAnalyzer.pm
+%%SITE_PERL%%/Plucene/Plugin/Analyzer/SnowballFilter.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Plucene/Plugin/Analyzer/SnowballAnalyzer/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Plucene/Plugin/Analyzer/SnowballAnalyzer
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Plucene/Plugin/Analyzer 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Plucene/Plugin 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Plucene/Plugin/Analyzer 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Plucene 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Plucene/Plugin 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Plucene 2>/dev/null || true