aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Pod-Parser
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2002-06-18 07:05:52 +0000
committerDoug Barton <dougb@FreeBSD.org>2002-06-18 07:05:52 +0000
commit794224f8a3b54b409cfa527f6a643a6bf22e7bca (patch)
tree47f3fc5a1911e564e5f32350d942f0206197a40e /textproc/p5-Pod-Parser
parent23ab7eff71ffbe54f5b8e4b8827f4a3d5c631a4d (diff)
downloadports-794224f8a3b54b409cfa527f6a643a6bf22e7bca.tar.gz
ports-794224f8a3b54b409cfa527f6a643a6bf22e7bca.zip
Maintainer timeout on this, and we've got several users complaining
about it. This patch causes the modules to prefer the stuff in PREFIX before the stuff in the base system, which allows it to find the newly installed File::Spec port. tobez has already committed a better fix to the base perl in RELENG_4, but it'll be a while before we can expect that to be commonplace.
Notes
Notes: svn path=/head/; revision=61482
Diffstat (limited to 'textproc/p5-Pod-Parser')
-rw-r--r--textproc/p5-Pod-Parser/Makefile3
-rw-r--r--textproc/p5-Pod-Parser/files/patch-use-ports-File-Spec98
2 files changed, 101 insertions, 0 deletions
diff --git a/textproc/p5-Pod-Parser/Makefile b/textproc/p5-Pod-Parser/Makefile
index 4c553be60ba6..18d4a2924eb3 100644
--- a/textproc/p5-Pod-Parser/Makefile
+++ b/textproc/p5-Pod-Parser/Makefile
@@ -26,4 +26,7 @@ MAN3= Pod::Checker.3 Pod::Find.3 Pod::InputObjects.3 \
MAN1PREFIX= ${PREFIX}
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+post-patch:
+ ${FIND} ${WRKSRC} -name \*.orig -exec ${RM} {} \;
+
.include <bsd.port.mk>
diff --git a/textproc/p5-Pod-Parser/files/patch-use-ports-File-Spec b/textproc/p5-Pod-Parser/files/patch-use-ports-File-Spec
new file mode 100644
index 000000000000..24a70d8463f1
--- /dev/null
+++ b/textproc/p5-Pod-Parser/files/patch-use-ports-File-Spec
@@ -0,0 +1,98 @@
+diff -ur ../PodParser-1.18-clean/lib/Pod/Find.pm ./lib/Pod/Find.pm
+--- ../PodParser-1.18-clean/lib/Pod/Find.pm Fri Sep 1 08:11:39 2000
++++ ./lib/Pod/Find.pm Sun Jun 16 12:55:40 2002
+@@ -48,7 +48,13 @@
+ use strict;
+ #use diagnostics;
+ use Exporter;
++
++# Added by FreeBSD ports to make sure newer version of File::Spec is used
++use Config;
++use lib $Config{installsitelib}; # installsitearch will be added automatically
++
+ use File::Spec;
++
+ use File::Find;
+ use Cwd;
+
+diff -ur ../PodParser-1.18-clean/lib/Pod/Usage.pm ./lib/Pod/Usage.pm
+--- ../PodParser-1.18-clean/lib/Pod/Usage.pm Thu Aug 10 14:39:45 2000
++++ ./lib/Pod/Usage.pm Sun Jun 16 12:55:18 2002
+@@ -400,6 +400,11 @@
+ use Carp;
+ use Config;
+ use Exporter;
++
++# Added by FreeBSD ports to make sure newer version of File::Spec is used
++use Config;
++use lib $Config{installsitelib}; # installsitearch will be added automatically
++
+ use File::Spec;
+
+ use vars qw(@ISA @EXPORT);
+diff -ur ../PodParser-1.18-clean/t/pod/find.t ./t/pod/find.t
+--- ../PodParser-1.18-clean/t/pod/find.t Fri Sep 1 08:25:41 2000
++++ ./t/pod/find.t Sun Jun 16 12:56:32 2002
+@@ -8,6 +8,11 @@
+ BEGIN { plan tests => 4 }
+
+ use Pod::Find qw(pod_find pod_where);
++
++# Added by FreeBSD ports to make sure newer version of File::Spec is used
++use Config;
++use lib $Config{installsitelib}; # installsitearch will be added automatically
++
+ use File::Spec;
+
+ # load successful
+diff -ur ../PodParser-1.18-clean/t/pod/testcmp.pl ./t/pod/testcmp.pl
+--- ../PodParser-1.18-clean/t/pod/testcmp.pl Thu Aug 10 14:05:40 2000
++++ ./t/pod/testcmp.pl Sun Jun 16 12:56:50 2002
+@@ -6,7 +6,13 @@
+ use Carp;
+ use Exporter;
+ use File::Basename;
++
++# Added by FreeBSD ports to make sure newer version of File::Spec is used
++use Config;
++use lib $Config{installsitelib}; # installsitearch will be added automatically
++
+ use File::Spec;
++
+ use FileHandle;
+
+ @ISA = qw(Exporter);
+diff -ur ../PodParser-1.18-clean/t/pod/testp2pt.pl ./t/pod/testp2pt.pl
+--- ../PodParser-1.18-clean/t/pod/testp2pt.pl Thu Aug 10 14:05:40 2000
++++ ./t/pod/testp2pt.pl Sun Jun 16 12:57:11 2002
+@@ -2,7 +2,13 @@
+
+ BEGIN {
+ use File::Basename;
++
++ # Added by FreeBSD ports to make sure newer version of File::Spec is used
++ use Config;
++ use lib $Config{installsitelib}; # installsitearch will be added automatically
++
+ use File::Spec;
++
+ use Cwd qw(abs_path);
+ push @INC, '..';
+ my $THISDIR = abs_path(dirname $0);
+diff -ur ../PodParser-1.18-clean/t/pod/testpchk.pl ./t/pod/testpchk.pl
+--- ../PodParser-1.18-clean/t/pod/testpchk.pl Thu Aug 10 14:05:40 2000
++++ ./t/pod/testpchk.pl Sun Jun 16 12:56:17 2002
+@@ -2,7 +2,13 @@
+
+ BEGIN {
+ use File::Basename;
++
++ # Added by FreeBSD ports to make sure newer version of File::Spec is used
++ use Config;
++ use lib $Config{installsitelib}; # installsitearch will be added automatically
++
+ use File::Spec;
++
+ push @INC, '..';
+ my $THISDIR = dirname $0;
+ unshift @INC, $THISDIR;