aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Pod-Tree
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-08-10 07:27:54 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-08-10 07:27:54 +0000
commit6f650508cac089de15b60756f0652fbbe793e931 (patch)
treecd5c805fa0c1d62d085ae2ac7b3e482378f1c690 /textproc/p5-Pod-Tree
parent7edd426d07405d688841c3d7b1d4dd67018dd202 (diff)
downloadports-6f650508cac089de15b60756f0652fbbe793e931.tar.gz
ports-6f650508cac089de15b60756f0652fbbe793e931.zip
Notes
Diffstat (limited to 'textproc/p5-Pod-Tree')
-rw-r--r--textproc/p5-Pod-Tree/Makefile44
-rw-r--r--textproc/p5-Pod-Tree/distinfo2
-rw-r--r--textproc/p5-Pod-Tree/pkg-descr4
-rw-r--r--textproc/p5-Pod-Tree/pkg-plist20
4 files changed, 70 insertions, 0 deletions
diff --git a/textproc/p5-Pod-Tree/Makefile b/textproc/p5-Pod-Tree/Makefile
new file mode 100644
index 000000000000..4b4a6212dad4
--- /dev/null
+++ b/textproc/p5-Pod-Tree/Makefile
@@ -0,0 +1,44 @@
+# ex:ts=8
+# Ports collection makefile for: p5-Pod-Tree
+# Date created: Aug 10, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= Pod-Tree
+PORTVERSION= 1.10
+CATEGORIES= textproc devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Pod
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Create a static syntax tree for a POD
+
+BUILD_DEPENDS= ${SITE_PERL}/HTML/Stream.pm:${PORTSDIR}/www/p5-HTML-Stream \
+ ${SITE_PERL}/Pod/Escapes.pm:${PORTSDIR}/textproc/p5-Pod-Escapes
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= perl2html.1 pod2html.1 pods2html.1
+MAN3= Pod::Tree.3 \
+ Pod::Tree::HTML.3 \
+ Pod::Tree::Node.3 \
+ Pod::Tree::PerlBin.3 \
+ Pod::Tree::PerlDist.3 \
+ Pod::Tree::PerlFunc.3 \
+ Pod::Tree::PerlLib.3 \
+ Pod::Tree::PerlMap.3 \
+ Pod::Tree::PerlPod.3 \
+ Pod::Tree::PerlTop.3 \
+ Pod::Tree::Pod.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= This port requires perl 5.6.0 or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Pod-Tree/distinfo b/textproc/p5-Pod-Tree/distinfo
new file mode 100644
index 000000000000..fbfeb9e99795
--- /dev/null
+++ b/textproc/p5-Pod-Tree/distinfo
@@ -0,0 +1,2 @@
+MD5 (Pod-Tree-1.10.tar.gz) = b7558bc5607560b24694d7c2ffdf3d71
+SIZE (Pod-Tree-1.10.tar.gz) = 53955
diff --git a/textproc/p5-Pod-Tree/pkg-descr b/textproc/p5-Pod-Tree/pkg-descr
new file mode 100644
index 000000000000..3607eea87710
--- /dev/null
+++ b/textproc/p5-Pod-Tree/pkg-descr
@@ -0,0 +1,4 @@
+Pod::Tree parses a POD into a static syntax tree. Applications walk the tree to
+recover the structure and content of the POD.
+
+WWW: http://search.cpan.org/dist/Pod-Tree/
diff --git a/textproc/p5-Pod-Tree/pkg-plist b/textproc/p5-Pod-Tree/pkg-plist
new file mode 100644
index 000000000000..5fc17ad1f819
--- /dev/null
+++ b/textproc/p5-Pod-Tree/pkg-plist
@@ -0,0 +1,20 @@
+bin/perl2html
+bin/pod2html
+bin/pods2html
+%%SITE_PERL%%/Pod/Tree.pm
+%%SITE_PERL%%/Pod/Tree/HTML.pm
+%%SITE_PERL%%/Pod/Tree/Node.pm
+%%SITE_PERL%%/Pod/Tree/PerlBin.pm
+%%SITE_PERL%%/Pod/Tree/PerlDist.pm
+%%SITE_PERL%%/Pod/Tree/PerlFunc.pm
+%%SITE_PERL%%/Pod/Tree/PerlLib.pm
+%%SITE_PERL%%/Pod/Tree/PerlMap.pm
+%%SITE_PERL%%/Pod/Tree/PerlPod.pm
+%%SITE_PERL%%/Pod/Tree/PerlTop.pm
+%%SITE_PERL%%/Pod/Tree/PerlUtil.pm
+%%SITE_PERL%%/Pod/Tree/Pod.pm
+@dirrm %%SITE_PERL%%/Pod/Tree
+@unexec rmdir %D/%%SITE_PERL%%/Pod 2>/dev/null || true
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod/Tree/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod/Tree
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Pod 2>/dev/null || true