aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Regexp-Log-Common/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-03-03 11:13:02 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-03-03 11:13:02 +0000
commit6dc7572495765eb1c8fee075144251f94ab51572 (patch)
tree74c17b683602c7c501e1d080c7cbabf4d4ee7f46 /textproc/p5-Regexp-Log-Common/Makefile
parent59d0d3b17ed00588ec1fbd384a0b4ee8b8fec04d (diff)
downloadports-6dc7572495765eb1c8fee075144251f94ab51572.tar.gz
ports-6dc7572495765eb1c8fee075144251f94ab51572.zip
Notes
Diffstat (limited to 'textproc/p5-Regexp-Log-Common/Makefile')
-rw-r--r--textproc/p5-Regexp-Log-Common/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/textproc/p5-Regexp-Log-Common/Makefile b/textproc/p5-Regexp-Log-Common/Makefile
new file mode 100644
index 000000000000..6e110b21886d
--- /dev/null
+++ b/textproc/p5-Regexp-Log-Common/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: textproc/p5-Regexp-Log-Common
+# Date created: 03 March 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Regexp-Log-Common
+PORTVERSION= 0.02
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Regexp
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Regexp::Log::Common, a parser for the Common Log Format
+
+BUILD_DEPENDS= ${SITE_PERL}/Regexp/Log.pm:${PORTSDIR}/textproc/p5-Regexp-Log
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Regexp::Log::Common.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Port requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>