aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Search-Estraier
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-07-11 15:11:14 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-07-11 15:11:14 +0000
commitcc79b6fa3bedb2a9054efa2ec5365916bdaf038e (patch)
tree5602fb60113c8d97f8e645a0bbf827ad8ca492da /textproc/p5-Search-Estraier
parent7ed90ed42a33181706c43c075964472b586a5930 (diff)
downloadports-cc79b6fa3bedb2a9054efa2ec5365916bdaf038e.tar.gz
ports-cc79b6fa3bedb2a9054efa2ec5365916bdaf038e.zip
Add p5-Search-Estraier 0.06, pure perl module to use Hyper Estraier
search engine. PR: ports/100073 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=167489
Diffstat (limited to 'textproc/p5-Search-Estraier')
-rw-r--r--textproc/p5-Search-Estraier/Makefile34
-rw-r--r--textproc/p5-Search-Estraier/distinfo3
-rw-r--r--textproc/p5-Search-Estraier/pkg-descr12
-rw-r--r--textproc/p5-Search-Estraier/pkg-plist6
4 files changed, 55 insertions, 0 deletions
diff --git a/textproc/p5-Search-Estraier/Makefile b/textproc/p5-Search-Estraier/Makefile
new file mode 100644
index 000000000000..bbf0279b4558
--- /dev/null
+++ b/textproc/p5-Search-Estraier/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Search-Estraier
+# Date created: 2006-07-11
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Search-Estraier
+PORTVERSION= 0.06
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Search
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Pure perl module to use Hyper Estraier search engine
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Search::Estraier.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # inherited from www/p5-libwww
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Search-Estraier/distinfo b/textproc/p5-Search-Estraier/distinfo
new file mode 100644
index 000000000000..07c75f29ddd7
--- /dev/null
+++ b/textproc/p5-Search-Estraier/distinfo
@@ -0,0 +1,3 @@
+MD5 (Search-Estraier-0.06.tar.gz) = 68ae8b6a6c7e3ee2b84a0be473299401
+SHA256 (Search-Estraier-0.06.tar.gz) = 15efb48444cca16b337c0786f6f96699c20d362b8f8f6d168656a55bdbc731a6
+SIZE (Search-Estraier-0.06.tar.gz) = 34863
diff --git a/textproc/p5-Search-Estraier/pkg-descr b/textproc/p5-Search-Estraier/pkg-descr
new file mode 100644
index 000000000000..16ab37ba66ba
--- /dev/null
+++ b/textproc/p5-Search-Estraier/pkg-descr
@@ -0,0 +1,12 @@
+This module is implementation of node API of Hyper Estraier. Since
+it's perl-only module with dependencies only on standard perl modules,
+it will run on all platforms on which perl runs. It doesn't require
+compilation or Hyper Estraier development files on target machine.
+
+It is implemented as multiple packages which closly resamble Ruby
+implementation. It also includes methods to manage nodes.
+
+There are few examples in scripts directory of this distribution.
+
+Author: Dobrica Pavlinusic, <dpavlin@rot13.org>
+WWW: http://search.cpan.org/dist/Search-Estraier/
diff --git a/textproc/p5-Search-Estraier/pkg-plist b/textproc/p5-Search-Estraier/pkg-plist
new file mode 100644
index 000000000000..283ffb2b2df5
--- /dev/null
+++ b/textproc/p5-Search-Estraier/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/Estraier/.packlist
+%%SITE_PERL%%/Search/Estraier.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Search/Estraier
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Search
+@dirrmtry %%SITE_PERL%%/Search