aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Search-Odeum/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-07-30 02:24:17 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-07-30 02:24:17 +0000
commit584dbd30382f702effe7095f825665ec2bb0ef05 (patch)
tree89f8d7adb8e6bb0df6f3d970e29b3d06e2af307f /textproc/p5-Search-Odeum/Makefile
parentc263bb1b8423b6965273e2f10a3c2bf6e42cd7d1 (diff)
downloadports-584dbd30382f702effe7095f825665ec2bb0ef05.tar.gz
ports-584dbd30382f702effe7095f825665ec2bb0ef05.zip
Notes
Diffstat (limited to 'textproc/p5-Search-Odeum/Makefile')
-rw-r--r--textproc/p5-Search-Odeum/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/textproc/p5-Search-Odeum/Makefile b/textproc/p5-Search-Odeum/Makefile
new file mode 100644
index 000000000000..33e6d25f7ace
--- /dev/null
+++ b/textproc/p5-Search-Odeum/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Search-Odeum
+# Date created: 2007-07-26
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Search-Odeum
+PORTVERSION= 0.02
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Search
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Perl interface to the Odeum inverted index API
+
+LIB_DEPENDS= qdbm:${PORTSDIR}/databases/qdbm
+
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV= CFLAGS="${CFLAGS}"
+PERL_CONFIGURE= yes
+
+MAN3= Search::Odeum.3 \
+ Search::Odeum::Document.3 \
+ Search::Odeum::Result.3
+
+.include <bsd.port.mk>