aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Senna
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2006-12-09 08:06:48 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2006-12-09 08:06:48 +0000
commit8ff181cd58f13bd30106300a1a417495706d85fb (patch)
treef5765c3fc984f1dce87a6b5b8a5989ed7c440d30 /textproc/p5-Senna
parent5e7adb1ea87331134d03ed81e962556ce69d528f (diff)
downloadports-8ff181cd58f13bd30106300a1a417495706d85fb.tar.gz
ports-8ff181cd58f13bd30106300a1a417495706d85fb.zip
- POD fixes (already reported to module author).
- Reduce warning in Senna::Symbol.
Notes
Notes: svn path=/head/; revision=179258
Diffstat (limited to 'textproc/p5-Senna')
-rw-r--r--textproc/p5-Senna/Makefile1
-rw-r--r--textproc/p5-Senna/files/patch-Index.pm71
-rw-r--r--textproc/p5-Senna/files/patch-Records.pm32
-rw-r--r--textproc/p5-Senna/files/patch-Select.pm24
-rw-r--r--textproc/p5-Senna/files/patch-Sort.pm14
-rw-r--r--textproc/p5-Senna/files/patch-Symbol.pm18
6 files changed, 160 insertions, 0 deletions
diff --git a/textproc/p5-Senna/Makefile b/textproc/p5-Senna/Makefile
index 2b143c1447ac..dbf185c6b8d0 100644
--- a/textproc/p5-Senna/Makefile
+++ b/textproc/p5-Senna/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Senna
PORTVERSION= 0.50
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= ../by-authors/id/D/DM/DMAKI/
diff --git a/textproc/p5-Senna/files/patch-Index.pm b/textproc/p5-Senna/files/patch-Index.pm
new file mode 100644
index 000000000000..0109d6b194a6
--- /dev/null
+++ b/textproc/p5-Senna/files/patch-Index.pm
@@ -0,0 +1,71 @@
+--- lib/Senna/Index.pm.orig Sun Aug 27 00:16:57 2006
++++ lib/Senna/Index.pm Wed Oct 25 14:27:07 2006
+@@ -126,10 +126,10 @@
+
+ use Senna::Index;
+
+- my $index = Senna::Index->new(path => '/path/to/index');
+- # $index = Senna::Index->open(pth => '/path/to/index');
++ my $index = Senna::Index->create(path => '/path/to/index');
++ # $index = Senna::Index->open(path => '/path/to/index');
+
+- $rc = $index->insert(key => $key, new => $new, old => $old);
++ $rc = $index->insert(key => $key, value => $new);
+ $rc = $index->delete(key => $key, value => $old_value);
+ $rc = $index->update(key => $key, new => $new, old => $old, section => $s);
+
+@@ -161,26 +161,47 @@
+ =head1 METHODS
+
+ =head2 delete
++
+ =head2 file_size_keys
++
+ =head2 file_size_lexicon
++
+ =head2 info
++
+ =head2 insert
++
+ =head2 inv_chunk_size
++
+ =head2 inv_seg_size
++
+ =head2 nrecords_keys
++
+ =head2 nrecords_lexicon
++
+ =head2 path
++
+ =head2 query_exec
++
+ =head2 rename
++
+ =head2 select
++
+ =head2 update
++
+ =head2 close
++
+ =head2 create
++
+ =head2 encoding
++
+ =head2 flags
++
+ =head2 initial_n_segments
++
+ =head2 key_size
++
+ =head2 open
++
+ =head2 remove
+
+ =head1 AUTHOR
+@@ -197,4 +218,4 @@
+
+ http://qwik.jp/senna - Senna Development Homepage
+
+-=cut
+\ No newline at end of file
++=cut
diff --git a/textproc/p5-Senna/files/patch-Records.pm b/textproc/p5-Senna/files/patch-Records.pm
new file mode 100644
index 000000000000..490f9458425d
--- /dev/null
+++ b/textproc/p5-Senna/files/patch-Records.pm
@@ -0,0 +1,32 @@
+--- lib/Senna/Records.pm.orig Wed Oct 18 15:16:06 2006
++++ lib/Senna/Records.pm Wed Oct 18 15:16:26 2006
+@@ -37,17 +37,29 @@
+ =head1 METHODS
+
+ =head2 new
++
+ =head2 open
++
+ =head2 next
++
+ =head2 close
++
+ =head2 curr_key
++
+ =head2 curr_score
++
+ =head2 nhits
++
+ =head2 find
++
+ =head2 difference
++
+ =head2 intersect
++
+ =head2 subtract
++
+ =head2 union
++
+ =head2 rewind
+
+ =head1 AUTHOR
diff --git a/textproc/p5-Senna/files/patch-Select.pm b/textproc/p5-Senna/files/patch-Select.pm
new file mode 100644
index 000000000000..f9fc6f8d7fe7
--- /dev/null
+++ b/textproc/p5-Senna/files/patch-Select.pm
@@ -0,0 +1,24 @@
+--- lib/Senna/OptArg/Select.pm.orig Wed Oct 18 18:59:04 2006
++++ lib/Senna/OptArg/Select.pm Wed Oct 18 18:59:15 2006
+@@ -35,12 +35,19 @@
+ =head1 METHODS
+
+ =head2 new
++
+ =head2 mode
++
+ =head2 similarity_threshold
++
+ =head2 max_interval
++
+ =head2 weight_vector
++
+ =head2 vector_size
++
+ =head2 func
++
+ =head2 func_arg
+
+-=cut
+\ No newline at end of file
++=cut
diff --git a/textproc/p5-Senna/files/patch-Sort.pm b/textproc/p5-Senna/files/patch-Sort.pm
new file mode 100644
index 000000000000..5daad2029a13
--- /dev/null
+++ b/textproc/p5-Senna/files/patch-Sort.pm
@@ -0,0 +1,14 @@
+--- lib/Senna/OptArg/Sort.pm.orig Wed Oct 18 18:58:06 2006
++++ lib/Senna/OptArg/Sort.pm Wed Oct 18 18:58:22 2006
+@@ -26,8 +26,11 @@
+ =head1 METHODS
+
+ =head2 new
++
+ =head2 compar
++
+ =head2 compar_arg
++
+ =head2 mode
+
+ =cut
diff --git a/textproc/p5-Senna/files/patch-Symbol.pm b/textproc/p5-Senna/files/patch-Symbol.pm
new file mode 100644
index 000000000000..06758904878c
--- /dev/null
+++ b/textproc/p5-Senna/files/patch-Symbol.pm
@@ -0,0 +1,18 @@
+--- lib/Senna/Symbol.pm.orig Wed Oct 18 14:04:47 2006
++++ lib/Senna/Symbol.pm Wed Oct 18 14:05:03 2006
+@@ -59,7 +59,7 @@
+ sub %s
+ {
+ my $self = shift;
+- my %args = @_;
++ my %%args = @_;
+ $self->xs_%s(@args{qw(key)});
+ }
+ EOSUB
+@@ -117,4 +117,4 @@
+
+ Development funded by Brazil Ltd. E<lt>http://dev.razil.jp/project/senna/E<gt>
+
+-=cut
+\ No newline at end of file
++=cut