aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Spreadsheet-ParseExcel
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2002-06-06 13:53:44 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2002-06-06 13:53:44 +0000
commita4a8ac16bee9280fba7146b6b761e9d94002ff3f (patch)
tree4a9fcc163f1572153b514f0e41b540522e6f71dd /textproc/p5-Spreadsheet-ParseExcel
parent2862d6f535273293fc58dbc18fc10b3c378ecef0 (diff)
downloadports-a4a8ac16bee9280fba7146b6b761e9d94002ff3f.tar.gz
ports-a4a8ac16bee9280fba7146b6b761e9d94002ff3f.zip
Updated to 0.26
Notes
Notes: svn path=/head/; revision=60696
Diffstat (limited to 'textproc/p5-Spreadsheet-ParseExcel')
-rw-r--r--textproc/p5-Spreadsheet-ParseExcel/Makefile20
-rw-r--r--textproc/p5-Spreadsheet-ParseExcel/distinfo2
-rw-r--r--textproc/p5-Spreadsheet-ParseExcel/pkg-descr8
-rw-r--r--textproc/p5-Spreadsheet-ParseExcel/pkg-plist36
4 files changed, 60 insertions, 6 deletions
diff --git a/textproc/p5-Spreadsheet-ParseExcel/Makefile b/textproc/p5-Spreadsheet-ParseExcel/Makefile
index 0afaff90b7c7..80ad22c2a2dc 100644
--- a/textproc/p5-Spreadsheet-ParseExcel/Makefile
+++ b/textproc/p5-Spreadsheet-ParseExcel/Makefile
@@ -6,22 +6,34 @@
#
PORTNAME= Spreadsheet-ParseExcel
-PORTVERSION= 0.2403
+PORTVERSION= 0.26
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Spreadsheet
PKGNAMEPREFIX= p5-
-MAINTAINER= skv@protey.ru
+MAINTAINER= skv@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/OLE/Storage_Lite.pm:${PORTSDIR}/devel/p5-OLE-Storage_Lite
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
+PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
MAN3= Spreadsheet::ParseExcel.3 \
- Spreadsheet::ParseExcel::Utility.3 \
- Spreadsheet::ParseExcel::SaveParser.3
+ Spreadsheet::ParseExcel::SaveParser.3 \
+ Spreadsheet::ParseExcel::Utility.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+post-install:
+
+.ifndef(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
+ @${MKDIR} ${EXAMPLESDIR}/Excel
+ @${INSTALL_DATA} ${WRKSRC}/sample/README ${WRKSRC}/sample/res* \
+ ${EXAMPLESDIR}
+ @${INSTALL_SCRIPT} ${WRKSRC}/sample/*.pl ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/sample/Excel/* ${EXAMPLESDIR}/Excel
+.endif
+
.include <bsd.port.mk>
diff --git a/textproc/p5-Spreadsheet-ParseExcel/distinfo b/textproc/p5-Spreadsheet-ParseExcel/distinfo
index 54e3df43c5d6..f1402f9545cc 100644
--- a/textproc/p5-Spreadsheet-ParseExcel/distinfo
+++ b/textproc/p5-Spreadsheet-ParseExcel/distinfo
@@ -1 +1 @@
-MD5 (Spreadsheet-ParseExcel-0.2403.tar.gz) = face0d4838e49802236266eda7801b20
+MD5 (Spreadsheet-ParseExcel-0.26.tar.gz) = a89b2e2f5bbc84ee8701ddec0c215312
diff --git a/textproc/p5-Spreadsheet-ParseExcel/pkg-descr b/textproc/p5-Spreadsheet-ParseExcel/pkg-descr
index e04f5d64493a..b7bbc22f6094 100644
--- a/textproc/p5-Spreadsheet-ParseExcel/pkg-descr
+++ b/textproc/p5-Spreadsheet-ParseExcel/pkg-descr
@@ -1 +1,7 @@
-Spreadsheet::ParseExcel - Get information from Excel file.
+Spreadsheet::ParseExcel makes you to get information from Excel95,
+Excel97, Excel2000 file.
+
+WWW: http://search.cpan.org/search?dist=Spreadsheet-ParseExcel
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/textproc/p5-Spreadsheet-ParseExcel/pkg-plist b/textproc/p5-Spreadsheet-ParseExcel/pkg-plist
index 687202b98572..7e606f2a0957 100644
--- a/textproc/p5-Spreadsheet-ParseExcel/pkg-plist
+++ b/textproc/p5-Spreadsheet-ParseExcel/pkg-plist
@@ -11,3 +11,39 @@ lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Spreadsheet/ParseExcel/.pack
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Spreadsheet 2>/dev/null || true
@dirrm lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet/ParseExcel
@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Spreadsheet 2>/dev/null || true
+%%PORTDOCS%%%%EXAMPLESDIR%%/Excel/AuthorK.xls
+%%PORTDOCS%%%%EXAMPLESDIR%%/Excel/AuthorK95.xls
+%%PORTDOCS%%%%EXAMPLESDIR%%/Excel/FmtTest.xls
+%%PORTDOCS%%%%EXAMPLESDIR%%/Excel/Rich.xls
+%%PORTDOCS%%%%EXAMPLESDIR%%/Excel/Test1904.xls
+%%PORTDOCS%%%%EXAMPLESDIR%%/Excel/Test1904_95.xls
+%%PORTDOCS%%%%EXAMPLESDIR%%/Excel/Test95.xls
+%%PORTDOCS%%%%EXAMPLESDIR%%/Excel/Test95J.xls
+%%PORTDOCS%%%%EXAMPLESDIR%%/Excel/Test97.xls
+%%PORTDOCS%%%%EXAMPLESDIR%%/Excel/Test97J.xls
+%%PORTDOCS%%%%EXAMPLESDIR%%/Excel/oem.xls
+%%PORTDOCS%%%%EXAMPLESDIR%%/Ilya.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/README
+%%PORTDOCS%%%%EXAMPLESDIR%%/chkFmt.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/chkInfo.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/dmpEx.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/dmpExH.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/dmpExHJ.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/dmpExJ.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/dmpExR.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/dmpExU.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/iftest.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/iftestj.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/res_fmt
+%%PORTDOCS%%%%EXAMPLESDIR%%/res_info
+%%PORTDOCS%%%%EXAMPLESDIR%%/res_oem
+%%PORTDOCS%%%%EXAMPLESDIR%%/res_rich
+%%PORTDOCS%%%%EXAMPLESDIR%%/res_sample
+%%PORTDOCS%%%%EXAMPLESDIR%%/res_samplej
+%%PORTDOCS%%%%EXAMPLESDIR%%/sample.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/sampleOEM.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/sample_j.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/smpFile.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/xls2csv.pl
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/Excel
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%