aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Spreadsheet-WriteExcel
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2003-02-20 16:33:26 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2003-02-20 16:33:26 +0000
commit628b215647a7f7c1e3232ad55bb67fd7cbdb9f14 (patch)
tree9dee99152b7b92fefea393e2a79a64b07ab74dff /textproc/p5-Spreadsheet-WriteExcel
parent029b209d330e5082cbae2c7100c55eed692fafd2 (diff)
downloadports-628b215647a7f7c1e3232ad55bb67fd7cbdb9f14.tar.gz
ports-628b215647a7f7c1e3232ad55bb67fd7cbdb9f14.zip
Conditionalise several dependencies on PERL_LEVEL to make those ports more
friendly for perl-5.8.0, which has those dependencies included into the base distribution. Sponsired by: Porta Software Ltd
Notes
Notes: svn path=/head/; revision=75949
Diffstat (limited to 'textproc/p5-Spreadsheet-WriteExcel')
-rw-r--r--textproc/p5-Spreadsheet-WriteExcel/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/textproc/p5-Spreadsheet-WriteExcel/Makefile b/textproc/p5-Spreadsheet-WriteExcel/Makefile
index c79fe848b1d8..4c8ae8dfa51d 100644
--- a/textproc/p5-Spreadsheet-WriteExcel/Makefile
+++ b/textproc/p5-Spreadsheet-WriteExcel/Makefile
@@ -15,7 +15,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Parse/RecDescent.pm:${PORTSDIR}/devel/p5-Parse-RecDescent \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/OLE/Storage_Lite.pm:${PORTSDIR}/devel/p5-OLE-Storage_Lite \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Date/Calc.pm:${PORTSDIR}/devel/p5-Date-Calc \
${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip
@@ -37,6 +36,12 @@ MAN3= Spreadsheet::WriteExcel.3 \
Spreadsheet::WriteExcel::Worksheet.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+.endif
+
pre-configure:
@${MV} ${WRKSRC}/WriteExcel/doc ${WRKSRC}
@${MV} ${WRKSRC}/WriteExcel/examples ${WRKSRC}
@@ -55,4 +60,4 @@ post-install:
${INSTALL_SCRIPT} ${WRKSRC}/examples/*.pl ${EXAMPLESDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>