aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-String-Divert
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-11-29 13:27:21 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-11-29 13:27:21 +0000
commitc0491943cb62b08f0d5db2e6570e669700155a33 (patch)
tree70c79a93b3f61f392aeb57782eb721bdb550ab23 /textproc/p5-String-Divert
parent8e972237d7f97377fe5f06dc09e49f8407499069 (diff)
downloadports-c0491943cb62b08f0d5db2e6570e669700155a33.tar.gz
ports-c0491943cb62b08f0d5db2e6570e669700155a33.zip
Notes
Diffstat (limited to 'textproc/p5-String-Divert')
-rw-r--r--textproc/p5-String-Divert/Makefile28
-rw-r--r--textproc/p5-String-Divert/distinfo3
-rw-r--r--textproc/p5-String-Divert/pkg-descr7
-rw-r--r--textproc/p5-String-Divert/pkg-plist6
4 files changed, 44 insertions, 0 deletions
diff --git a/textproc/p5-String-Divert/Makefile b/textproc/p5-String-Divert/Makefile
new file mode 100644
index 000000000000..d950b723fa12
--- /dev/null
+++ b/textproc/p5-String-Divert/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: textproc/p5-String-Divert
+# Date created: 29 November 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= String-Divert
+PORTVERSION= 0.96
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= String
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= String::Divert - String Object supporting Folding and Diversions
+
+PERL_CONFIGURE= yes
+
+MAN3= String::Divert.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-String-Divert/distinfo b/textproc/p5-String-Divert/distinfo
new file mode 100644
index 000000000000..397ac99a15ca
--- /dev/null
+++ b/textproc/p5-String-Divert/distinfo
@@ -0,0 +1,3 @@
+MD5 (String-Divert-0.96.tar.gz) = c574d757af76d55819d18654d1603b48
+SHA256 (String-Divert-0.96.tar.gz) = 07b6520d0516c8594bdbc20357ad4f68bcede1ec4e5105386e0a3437563ebaa3
+SIZE (String-Divert-0.96.tar.gz) = 10960
diff --git a/textproc/p5-String-Divert/pkg-descr b/textproc/p5-String-Divert/pkg-descr
new file mode 100644
index 000000000000..90e63216f126
--- /dev/null
+++ b/textproc/p5-String-Divert/pkg-descr
@@ -0,0 +1,7 @@
+String::Divert is small Perl 5 module providing a scalar-like string
+object with some overloaded operators, supporting the concept of Folding
+and Diversion. This allows nested generation of structured output. The
+idea is to decouple the sequential generation of output from the nested
+and non-sequential structure of the output.
+
+WWW: http://search.cpan.org/dist/String-Divert/
diff --git a/textproc/p5-String-Divert/pkg-plist b/textproc/p5-String-Divert/pkg-plist
new file mode 100644
index 000000000000..fd0f2c56d4a6
--- /dev/null
+++ b/textproc/p5-String-Divert/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/String/Divert.pm
+%%SITE_PERL%%/String/Divert.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/String/Divert/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/String/Divert 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/String 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/String 2>/dev/null || true