aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-String-Fraction
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-05-16 22:42:55 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-05-16 22:42:55 +0000
commit9f830715e5cb4349c7b7f18a3fcb3598d3d3bd2e (patch)
treef8eb7aee8a5e8df76ad09c06a57478c5d4ca769d /textproc/p5-String-Fraction
parentb663d9f7408f0a416e29cf82fd2829623954b30a (diff)
downloadports-9f830715e5cb4349c7b7f18a3fcb3598d3d3bd2e.tar.gz
ports-9f830715e5cb4349c7b7f18a3fcb3598d3d3bd2e.zip
Adding port textproc/p5-String-Fraction, convert fractions into unicode chars.
Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=162611
Diffstat (limited to 'textproc/p5-String-Fraction')
-rw-r--r--textproc/p5-String-Fraction/Makefile31
-rw-r--r--textproc/p5-String-Fraction/distinfo3
-rw-r--r--textproc/p5-String-Fraction/pkg-descr6
-rw-r--r--textproc/p5-String-Fraction/pkg-plist5
4 files changed, 45 insertions, 0 deletions
diff --git a/textproc/p5-String-Fraction/Makefile b/textproc/p5-String-Fraction/Makefile
new file mode 100644
index 000000000000..7140f74344ce
--- /dev/null
+++ b/textproc/p5-String-Fraction/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: String-Fraction
+# Date created: 16 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= String-Fraction
+PORTVERSION= 0.20
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= String
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Convert fractions into unicode chars
+
+BUILD_DEPENDS= ${SITE_PERL}/HTML/Fraction.pm:${PORTSDIR}/textproc/p5-HTML-Fraction
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= String::Fraction.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-String-Fraction/distinfo b/textproc/p5-String-Fraction/distinfo
new file mode 100644
index 000000000000..abb9b5811a84
--- /dev/null
+++ b/textproc/p5-String-Fraction/distinfo
@@ -0,0 +1,3 @@
+MD5 (String-Fraction-0.20.tar.gz) = bda7166cd6b0fb5329a36cf20415d8c3
+SHA256 (String-Fraction-0.20.tar.gz) = 679ea7152387697e11c5825c05360d742d24db194d51ea86a7f80a06ad320b09
+SIZE (String-Fraction-0.20.tar.gz) = 1979
diff --git a/textproc/p5-String-Fraction/pkg-descr b/textproc/p5-String-Fraction/pkg-descr
new file mode 100644
index 000000000000..c529f5d5f473
--- /dev/null
+++ b/textproc/p5-String-Fraction/pkg-descr
@@ -0,0 +1,6 @@
+This module functions identically to its superclass HTML::Fraction, but
+rather than converting fractions into HTML entities they are replaced by
+the unicode characters for those fractions.
+
+WWW: http://search.cpan.org/dist/String-Fraction
+Author: Mark Fowler <mark@twoshortplanks.com>
diff --git a/textproc/p5-String-Fraction/pkg-plist b/textproc/p5-String-Fraction/pkg-plist
new file mode 100644
index 000000000000..717ccb7a32b5
--- /dev/null
+++ b/textproc/p5-String-Fraction/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/String/Fraction.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/String/Fraction/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/String/Fraction
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/String
+@dirrmtry %%SITE_PERL%%/String