aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Template-Tiny
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-03-20 18:52:44 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-03-20 18:52:44 +0000
commit00c8384ee2dc95d2b3b987e6525e7301ae8da55a (patch)
tree27b51d2068f1d1a9e272f66f791179bc5c0c8d0a /textproc/p5-Template-Tiny
parentf2b591d7313f7c699d4110c0bce085df34b4a4fc (diff)
downloadports-00c8384ee2dc95d2b3b987e6525e7301ae8da55a.tar.gz
ports-00c8384ee2dc95d2b3b987e6525e7301ae8da55a.zip
Template::Tiny is a reimplementation of a partial subset of the Template
Toolkit in as few lines of code as possible. It is intended for use in light-usage, low-memory, or low-cpu templating situations, where you may need to upgrade to the full feature set in the future, or if you want the familiarity of TT-style templates. It is intended to have fully-compatible template and stash usage, with a limited by similar Perl API. Unlike Template Toolkit, Template::Tiny will process templates without a compile phase (but despite this is still quicker, owing to heavy use of the Perl regular expression engine. WWW: http://search.cpan.org/dist/Template-Tiny/ PR: ports/144823 Submitted by: ports at c0decafe.net
Notes
Notes: svn path=/head/; revision=251295
Diffstat (limited to 'textproc/p5-Template-Tiny')
-rw-r--r--textproc/p5-Template-Tiny/Makefile25
-rw-r--r--textproc/p5-Template-Tiny/distinfo3
-rw-r--r--textproc/p5-Template-Tiny/pkg-descr15
-rw-r--r--textproc/p5-Template-Tiny/pkg-plist5
4 files changed, 48 insertions, 0 deletions
diff --git a/textproc/p5-Template-Tiny/Makefile b/textproc/p5-Template-Tiny/Makefile
new file mode 100644
index 000000000000..8ebf6ea7de4f
--- /dev/null
+++ b/textproc/p5-Template-Tiny/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Template-Tiny
+# Date created: 2010-03-17
+# Whom: ports@c0decafe.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= Template-Tiny
+PORTVERSION= 0.11
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@c0decafe.net
+COMMENT= Template Toolkit reimplemented in as little code as possible
+
+BUILD_DEPENDS= p5-Capture-Tiny>=0.07:${PORTSDIR}/devel/p5-Capture-Tiny
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MAN3= Template::Tiny.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Template-Tiny/distinfo b/textproc/p5-Template-Tiny/distinfo
new file mode 100644
index 000000000000..27e97b23173a
--- /dev/null
+++ b/textproc/p5-Template-Tiny/distinfo
@@ -0,0 +1,3 @@
+MD5 (Template-Tiny-0.11.tar.gz) = 5bb697dff7ff41f6894906233b205560
+SHA256 (Template-Tiny-0.11.tar.gz) = 7d2583bb186f8acbba05fcdbf51d52aaa3ef37fa8e0eb5d9dce99d3bed2f62c4
+SIZE (Template-Tiny-0.11.tar.gz) = 16129
diff --git a/textproc/p5-Template-Tiny/pkg-descr b/textproc/p5-Template-Tiny/pkg-descr
new file mode 100644
index 000000000000..b99f907c17c6
--- /dev/null
+++ b/textproc/p5-Template-Tiny/pkg-descr
@@ -0,0 +1,15 @@
+Template::Tiny is a reimplementation of a partial subset of the Template
+Toolkit in as few lines of code as possible.
+
+It is intended for use in light-usage, low-memory, or low-cpu templating
+situations, where you may need to upgrade to the full feature set in the
+future, or if you want the familiarity of TT-style templates.
+
+It is intended to have fully-compatible template and stash usage, with a
+limited by similar Perl API.
+
+Unlike Template Toolkit, Template::Tiny will process templates without a
+compile phase (but despite this is still quicker, owing to heavy use of
+the Perl regular expression engine.
+
+WWW: http://search.cpan.org/dist/Template-Tiny/
diff --git a/textproc/p5-Template-Tiny/pkg-plist b/textproc/p5-Template-Tiny/pkg-plist
new file mode 100644
index 000000000000..2e262b09305b
--- /dev/null
+++ b/textproc/p5-Template-Tiny/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Template/Tiny.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Tiny/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Tiny
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template
+@dirrmtry %%SITE_PERL%%/Template