aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Text-Chomp
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-09 13:00:35 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-09 13:00:35 +0000
commit3ad30f435ebf9dfcd28c85391a98a9c405301560 (patch)
tree927a60138a4b010bb4950a6161c7c59d3c4295b5 /textproc/p5-Text-Chomp
parentaa4939a64c7b5ad54454e4eb7d4511e04a303095 (diff)
downloadports-3ad30f435ebf9dfcd28c85391a98a9c405301560.tar.gz
ports-3ad30f435ebf9dfcd28c85391a98a9c405301560.zip
Notes
Diffstat (limited to 'textproc/p5-Text-Chomp')
-rw-r--r--textproc/p5-Text-Chomp/Makefile29
-rw-r--r--textproc/p5-Text-Chomp/distinfo2
-rw-r--r--textproc/p5-Text-Chomp/pkg-descr7
-rw-r--r--textproc/p5-Text-Chomp/pkg-plist5
4 files changed, 43 insertions, 0 deletions
diff --git a/textproc/p5-Text-Chomp/Makefile b/textproc/p5-Text-Chomp/Makefile
new file mode 100644
index 000000000000..4f882adeeca4
--- /dev/null
+++ b/textproc/p5-Text-Chomp/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Text-Chomp
+# Date created: 08 Oct 2005
+# Whom: Jason Burgess <dev@fenux.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-Chomp
+PORTVERSION= 0.02
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= dev@fenux.net
+COMMENT= A module implementing a portable chomp
+
+PERL_CONFIGURE= yes
+USE_REINPLACE= yes
+
+MAN3= Text::Chomp.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500806
+IGNORE= needs Perl 5.8.6 or above (lang/perl5.8)
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Text-Chomp/distinfo b/textproc/p5-Text-Chomp/distinfo
new file mode 100644
index 000000000000..92144f3020ef
--- /dev/null
+++ b/textproc/p5-Text-Chomp/distinfo
@@ -0,0 +1,2 @@
+MD5 (Text-Chomp-0.02.tar.gz) = 4e0c9d3faa4653a8d43ffeb29968f0d7
+SIZE (Text-Chomp-0.02.tar.gz) = 2747
diff --git a/textproc/p5-Text-Chomp/pkg-descr b/textproc/p5-Text-Chomp/pkg-descr
new file mode 100644
index 000000000000..eccd46997172
--- /dev/null
+++ b/textproc/p5-Text-Chomp/pkg-descr
@@ -0,0 +1,7 @@
+This module implements a single function, tchomp, which will remove all known
+line separators.
+
+The regular chomp() works only on the value in $/, which can be difficult if
+working in multi-platform environments.
+
+WWW: http://search.cpan.org/dist/Text-Chomp/
diff --git a/textproc/p5-Text-Chomp/pkg-plist b/textproc/p5-Text-Chomp/pkg-plist
new file mode 100644
index 000000000000..fa47e1a0a37d
--- /dev/null
+++ b/textproc/p5-Text-Chomp/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Text/Chomp.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Chomp/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Chomp
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Text 2>/dev/null || true