aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Text-Diff-HTML
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-09-28 14:06:58 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-09-28 14:06:58 +0000
commit976a924a4a6337b3955b2c0181d54e2c4e2ec399 (patch)
tree1ad0fb16b70920838a5950c906e30ae828143f6d /textproc/p5-Text-Diff-HTML
parent1431b0c3d81054d3cc37d0c5203624faec57a7ec (diff)
downloadports-976a924a4a6337b3955b2c0181d54e2c4e2ec399.tar.gz
ports-976a924a4a6337b3955b2c0181d54e2c4e2ec399.zip
Add p5-Text-Diff-HTML, a perl module to format unified diffs as XHTML.
Notes
Notes: svn path=/head/; revision=143692
Diffstat (limited to 'textproc/p5-Text-Diff-HTML')
-rw-r--r--textproc/p5-Text-Diff-HTML/Makefile32
-rw-r--r--textproc/p5-Text-Diff-HTML/distinfo2
-rw-r--r--textproc/p5-Text-Diff-HTML/pkg-descr12
-rw-r--r--textproc/p5-Text-Diff-HTML/pkg-plist3
4 files changed, 49 insertions, 0 deletions
diff --git a/textproc/p5-Text-Diff-HTML/Makefile b/textproc/p5-Text-Diff-HTML/Makefile
new file mode 100644
index 000000000000..e8096aa576ef
--- /dev/null
+++ b/textproc/p5-Text-Diff-HTML/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: textproc/p5-Text-Diff-HTML
+# Date created: 28 September 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-Diff-HTML
+PORTVERSION= 0.04
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Text::Diff::HTML - XHTML format for Text::Diff::Unified
+
+BUILD_DEPENDS= ${SITE_PERL}/Text/Diff.pm:${PORTSDIR}/textproc/p5-Text-Diff \
+ ${SITE_PERL}/${PERL_ARCH}/HTML/Entities.pm:${PORTSDIR}/www/p5-HTML-Parser
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Text::Diff::HTML.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Port requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Text-Diff-HTML/distinfo b/textproc/p5-Text-Diff-HTML/distinfo
new file mode 100644
index 000000000000..263fa7470492
--- /dev/null
+++ b/textproc/p5-Text-Diff-HTML/distinfo
@@ -0,0 +1,2 @@
+MD5 (Text-Diff-HTML-0.04.tar.gz) = cd8a50dd2f9d90be1f949906441035c1
+SIZE (Text-Diff-HTML-0.04.tar.gz) = 5375
diff --git a/textproc/p5-Text-Diff-HTML/pkg-descr b/textproc/p5-Text-Diff-HTML/pkg-descr
new file mode 100644
index 000000000000..7ce9b976def6
--- /dev/null
+++ b/textproc/p5-Text-Diff-HTML/pkg-descr
@@ -0,0 +1,12 @@
+This class subclasses Text::Diff::Unified, a formatting class provided
+by the Text::Diff module, to add XHTML markup to the unified diff
+format. For details on the interface of the diff() function, see the
+Text::Diff documentation.
+
+In the XHTML formatted by this module, the contents of the diff returned
+by diff() are wrapped in a <div> element, as is each hunk of the diff.
+Within each hunk, all content is properly HTML encoded using
+HTML::Entities, and the various sections of the diff are marked up with
+the appropriate XHTML elements.
+
+WWW: http://search.cpan.org/dist/Text-Diff-HTML/
diff --git a/textproc/p5-Text-Diff-HTML/pkg-plist b/textproc/p5-Text-Diff-HTML/pkg-plist
new file mode 100644
index 000000000000..1d1b9c052857
--- /dev/null
+++ b/textproc/p5-Text-Diff-HTML/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/Text/Diff/HTML.pm
+@unexec rmdir %D/%%SITE_PERL%%/Text/Diff 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Text 2>/dev/null || true