aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Text-NSP/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-04-23 02:37:05 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-04-23 02:37:05 +0000
commitc8e7cef3493a8c7c333adcfca22529c6befdb52c (patch)
tree7366af620e12ccd80dfed00defd89ce8e81c861b /textproc/p5-Text-NSP/Makefile
parent8e86501b968dd72a122b2343cbb0027aa86ba88c (diff)
downloadports-c8e7cef3493a8c7c333adcfca22529c6befdb52c.tar.gz
ports-c8e7cef3493a8c7c333adcfca22529c6befdb52c.zip
- update to 0.91
Notes
Notes: svn path=/head/; revision=160191
Diffstat (limited to 'textproc/p5-Text-NSP/Makefile')
-rw-r--r--textproc/p5-Text-NSP/Makefile33
1 files changed, 27 insertions, 6 deletions
diff --git a/textproc/p5-Text-NSP/Makefile b/textproc/p5-Text-NSP/Makefile
index 16416931c0a6..f198130bb8e6 100644
--- a/textproc/p5-Text-NSP/Makefile
+++ b/textproc/p5-Text-NSP/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Text-NSP
-PORTVERSION= 0.73
+PORTVERSION= 0.91
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Text
@@ -22,10 +22,30 @@ MAN1= combig.pl.1 count.pl.1 \
huge-combine.pl.1 huge-count.pl.1 \
kocos.pl.1 rank.pl.1 \
sort-bigrams.pl.1 split-data.pl.1 statistic.pl.1
-MAN3= pmi.3 rightFisher.3 measure3d.3 \
- tmi.3 leftFisher.3 measure2d.3 \
- odds.3 ll.3 ll3.3 dice.3 x2.3 \
- phi.3 tscore.3 tmi3.3
+MAN3= Text::NSP.3 Text::NSP::Measures.3 \
+ Text::NSP::Measures::2D.3 \
+ Text::NSP::Measures::2D::CHI::tscore.3 \
+ Text::NSP::Measures::2D::Fisher.3 \
+ Text::NSP::Measures::2D::Fisher::right.3 \
+ Text::NSP::Measures::2D::Fisher2.3 \
+ Text::NSP::Measures::2D::Fisher2::left.3 \
+ Text::NSP::Measures::2D::Fisher2::right.3 \
+ Text::NSP::Measures::2D::Fisher2::twotailed.3 \
+ Text::NSP::Measures::2D::MI::ll.3 \
+ Text::NSP::Measures::2D::odds.3 \
+ Text::NSP::Measures::2D::MI::pmi.3 \
+ Text::NSP::Measures::2D::dice.3 \
+ Text::NSP::Measures::2D::CHI.3 \
+ Text::NSP::Measures::2D::Fisher::left.3 \
+ Text::NSP::Measures::2D::CHI::phi.3 \
+ Text::NSP::Measures::2D::MI::tmi.3 \
+ Text::NSP::Measures::2D::Fisher::twotailed.3 \
+ Text::NSP::Measures::2D::MI.3 \
+ Text::NSP::Measures::2D::CHI::x2.3 \
+ Text::NSP::Measures::3D.3 \
+ Text::NSP::Measures::3D::MI.3 \
+ Text::NSP::Measures::3D::MI::ll.3 \
+ Text::NSP::Measures::3D::MI::tmi.3
post-patch:
@${REINPLACE_CMD} -e \
@@ -35,6 +55,7 @@ post-patch:
${REINPLACE_CMD} -e 's|/usr/local/bin/perl|/usr/bin/env perl|'
@${FIND} ${WRKSRC} -name "*.p[lm]" |${XARGS} \
${REINPLACE_CMD} -e 's|split.*(/:/, $$ENV{PATH})|@INC|'
+ @${FIND} ${WRKSRC} -name "*.bak" | ${XARGS} ${RM}
post-install:
@${CAT} ${PKGMESSAGE} | ${SED} -e "s:%%DOCSDIR%%:${DOCSDIR}:g"
@@ -47,7 +68,7 @@ pre-patch:
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500800
-IGNORE= This port requires perl 5.8.0 or later. Install lang/perl5.8 then try again
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 then try again
.endif
.include <bsd.port.post.mk>