aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Text-NSP
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2005-07-18 10:47:09 +0000
committerErwin Lansing <erwin@FreeBSD.org>2005-07-18 10:47:09 +0000
commiteecbae4c35b890524625f467eb3ee8d6e3ef7cae (patch)
tree59788db32efe14c074483b4b15120c879cdfdb1c /textproc/p5-Text-NSP
parent5aaa15832e35c8ce03059bcdcd6dc7158c4cda70 (diff)
downloadports-eecbae4c35b890524625f467eb3ee8d6e3ef7cae.tar.gz
ports-eecbae4c35b890524625f467eb3ee8d6e3ef7cae.zip
Add p5-Text-NSP 0.71, perl5 modules for Ngram Statistics Package.
PR: ports/72190 Submitted by: Cheng-Lung Sung <clsung@dragon2.net>
Notes
Notes: svn path=/head/; revision=139491
Diffstat (limited to 'textproc/p5-Text-NSP')
-rw-r--r--textproc/p5-Text-NSP/Makefile53
-rw-r--r--textproc/p5-Text-NSP/distinfo2
-rw-r--r--textproc/p5-Text-NSP/files/patch-Makefile.PL22
-rw-r--r--textproc/p5-Text-NSP/pkg-descr14
-rw-r--r--textproc/p5-Text-NSP/pkg-message7
-rw-r--r--textproc/p5-Text-NSP/pkg-plist71
6 files changed, 169 insertions, 0 deletions
diff --git a/textproc/p5-Text-NSP/Makefile b/textproc/p5-Text-NSP/Makefile
new file mode 100644
index 000000000000..e40808653690
--- /dev/null
+++ b/textproc/p5-Text-NSP/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: p5-Text-NSP
+# Date created: Sep 30 2004
+# Whom: Cheng-Lung Sung <clsung@dragon2.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-NSP
+PORTVERSION= 0.71
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Perl5 modules for Ngram Statistics Package
+
+PERL_CONFIGURE= yes
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+
+MAN1= combig.pl.1 count.pl.1 \
+ huge-combine.pl.1 huge-count.pl.1 \
+ kocos.pl.1 rank.pl.1 \
+ sort-bigrams.pl.1 split-data.pl.1 statistic.pl.1
+MAN3= pmi.3 rightFisher.3 measure3d.3 \
+ tmi.3 leftFisher.3 measure2d.3 \
+ odds.3 ll.3 ll3.3 dice.3 x2.3 \
+ phi.3 tscore.3 tmi3.3
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's,$(SITEPREFIX)/doc,$(SITEPREFIX)/share/doc/${PKGNAMEPREFIX}${PORTNAME},' \
+ ${WRKSRC}/Makefile.PL
+ @${FIND} ${WRKSRC} -name "*.pl" |${XARGS} \
+ ${REINPLACE_CMD} -e 's|/usr/local/bin/perl|/usr/bin/env perl|'
+ @${FIND} ${WRKSRC} -name "*.p[lm]" |${XARGS} \
+ ${REINPLACE_CMD} -e 's|split.*(/:/, $$ENV{PATH})|@INC|'
+
+post-install:
+ @${CAT} ${PKGMESSAGE} | ${SED} -e "s:%%DOCSDIR%%:${DOCSDIR}:g"
+
+.if defined(NOPORTDOCS)
+pre-patch:
+ @${REINPLACE_CMD} -e \
+ "s,'html',''," ${WRKSRC}/Makefile.PL
+.endif
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= This port requires perl 5.8.0 or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Text-NSP/distinfo b/textproc/p5-Text-NSP/distinfo
new file mode 100644
index 000000000000..2c632f176f7c
--- /dev/null
+++ b/textproc/p5-Text-NSP/distinfo
@@ -0,0 +1,2 @@
+MD5 (Text-NSP-0.71.tar.gz) = ac1a9d2bfd035a2fedd64cf0fa11ebd0
+SIZE (Text-NSP-0.71.tar.gz) = 603295
diff --git a/textproc/p5-Text-NSP/files/patch-Makefile.PL b/textproc/p5-Text-NSP/files/patch-Makefile.PL
new file mode 100644
index 000000000000..cfe01cde9e3c
--- /dev/null
+++ b/textproc/p5-Text-NSP/files/patch-Makefile.PL
@@ -0,0 +1,22 @@
+--- Makefile.PL.orig Fri Jun 18 06:18:30 2004
++++ Makefile.PL Thu Sep 30 10:39:29 2004
+@@ -240,19 +240,6 @@
+ @pod2html --outfile=$(SITEPREFIX)/doc/html/Todo.html --infile=Docs/Todo.pod --title="NSP Todo"
+ @pod2html --outfile=$(SITEPREFIX)/doc/html/Usage.html --infile=Docs/Usage.pod --title="NSP Usage"
+
+-# general documentation to man/man3
+-
+- @$(MKPATH) $(SITEPREFIX)/man/man3
+-
+- @echo "Installing man page documentation in $(SITEPREFIX)/man/man3"
+-
+- @pod2man Docs/FAQ.pod $(SITEPREFIX)/man/man3/FAQ.$(MAN3EXT)
+- @pod2man Docs/NewStats.pod $(SITEPREFIX)/man/man3/NewStats.$(MAN3EXT)
+- @pod2man Docs/Measures.pod $(SITEPREFIX)/man/man3/Measures.$(MAN3EXT)
+- @pod2man Docs/README.pod $(SITEPREFIX)/man/man3/README.$(MAN3EXT)
+- @pod2man Docs/Todo.pod $(SITEPREFIX)/man/man3/Todo.$(MAN3EXT)
+- @pod2man Docs/Usage.pod $(SITEPREFIX)/man/man3/Usage.$(MAN3EXT)
+-
+ # general documentation to doc/pod
+
+ @echo "Installing pod documentation in $(SITEPREFIX)/doc/pod"
diff --git a/textproc/p5-Text-NSP/pkg-descr b/textproc/p5-Text-NSP/pkg-descr
new file mode 100644
index 000000000000..345d05b976c3
--- /dev/null
+++ b/textproc/p5-Text-NSP/pkg-descr
@@ -0,0 +1,14 @@
+Text::NSP - The Ngram Statistic Package allows a user to count
+sequences of Ngrams in large corpora of text, and measure their
+association.
+
+The module NSP.pm is a stub that doesn't have any real functionality.
+The real work is done by five programs:
+
+count.pl statistic.pl rank.pl combig.pl kocos.pl
+
+These are not modules, and are run from the command line.
+
+WWW: http://search.cpan.org/dist/p5-Text-NSP/
+
+- Cheng-Lung Sung
diff --git a/textproc/p5-Text-NSP/pkg-message b/textproc/p5-Text-NSP/pkg-message
new file mode 100644
index 000000000000..2274df50edb7
--- /dev/null
+++ b/textproc/p5-Text-NSP/pkg-message
@@ -0,0 +1,7 @@
+************************************************************
+All scripts have extensive command help and documentation
+in %%DOCSDIR%%/.
+
+See %%DOCSDIR%%/pod/README.pod for an extensive description.
+
+************************************************************
diff --git a/textproc/p5-Text-NSP/pkg-plist b/textproc/p5-Text-NSP/pkg-plist
new file mode 100644
index 000000000000..af6d40ef0100
--- /dev/null
+++ b/textproc/p5-Text-NSP/pkg-plist
@@ -0,0 +1,71 @@
+bin/statistic.pl
+bin/split-data.pl
+bin/combig-script.sh
+bin/huge-count.pl
+bin/rank-script.sh
+bin/kocos.pl
+bin/huge-combine.pl
+bin/count.pl
+bin/rank.pl
+bin/kocos-script.sh
+bin/combig.pl
+bin/sort-bigrams.pl
+%%SITE_PERL%%/auto/Text/NSP/autosplit.ix
+%%SITE_PERL%%/pmi.pm
+%%SITE_PERL%%/rightFisher.pm
+%%SITE_PERL%%/tmi3.pm
+%%SITE_PERL%%/measure3d.pm
+%%SITE_PERL%%/odds.pm
+%%SITE_PERL%%/ll3.pm
+%%SITE_PERL%%/ll.pm
+%%SITE_PERL%%/dice.pm
+%%SITE_PERL%%/x2.pm
+%%SITE_PERL%%/measure2d.pm
+%%SITE_PERL%%/leftFisher.pm
+%%SITE_PERL%%/phi.pm
+%%SITE_PERL%%/tmi.pm
+%%SITE_PERL%%/tscore.pm
+%%SITE_PERL%%/Text/NSP.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/NSP/.packlist
+%%PORTDOCS%%%%DOCSDIR%%/html/dice.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ll.html
+%%PORTDOCS%%%%DOCSDIR%%/html/ll3.html
+%%PORTDOCS%%%%DOCSDIR%%/html/odds.html
+%%PORTDOCS%%%%DOCSDIR%%/html/phi.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tmi.html
+%%PORTDOCS%%%%DOCSDIR%%/html/pmi.html
+%%PORTDOCS%%%%DOCSDIR%%/html/tscore.html
+%%PORTDOCS%%%%DOCSDIR%%/html/x2.html
+%%PORTDOCS%%%%DOCSDIR%%/html/leftFisher.html
+%%PORTDOCS%%%%DOCSDIR%%/html/rightFisher.html
+%%PORTDOCS%%%%DOCSDIR%%/html/measure2d.html
+%%PORTDOCS%%%%DOCSDIR%%/html/measure3d.html
+%%PORTDOCS%%%%DOCSDIR%%/html/count.html
+%%PORTDOCS%%%%DOCSDIR%%/html/statistic.html
+%%PORTDOCS%%%%DOCSDIR%%/html/rank.html
+%%PORTDOCS%%%%DOCSDIR%%/html/kocos.html
+%%PORTDOCS%%%%DOCSDIR%%/html/combig.html
+%%PORTDOCS%%%%DOCSDIR%%/html/huge-count.html
+%%PORTDOCS%%%%DOCSDIR%%/html/huge-combine.html
+%%PORTDOCS%%%%DOCSDIR%%/html/sort-bigrams.html
+%%PORTDOCS%%%%DOCSDIR%%/html/split-data.html
+%%PORTDOCS%%%%DOCSDIR%%/html/FAQ.html
+%%PORTDOCS%%%%DOCSDIR%%/html/NewStats.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Measures.html
+%%PORTDOCS%%%%DOCSDIR%%/html/README.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Todo.html
+%%PORTDOCS%%%%DOCSDIR%%/html/Usage.html
+%%PORTDOCS%%%%DOCSDIR%%/pod/FAQ.pod
+%%PORTDOCS%%%%DOCSDIR%%/pod/NewStats.pod
+%%PORTDOCS%%%%DOCSDIR%%/pod/Measures.pod
+%%PORTDOCS%%%%DOCSDIR%%/pod/README.pod
+%%PORTDOCS%%%%DOCSDIR%%/pod/Todo.pod
+%%PORTDOCS%%%%DOCSDIR%%/pod/Usage.pod
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/pod
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/NSP
+@dirrm %%SITE_PERL%%/auto/Text/NSP
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/auto/Text 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Text 2>/dev/null || true