aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Text-Similarity/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2004-10-28 12:57:52 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2004-10-28 12:57:52 +0000
commitc0a019ffac3154c3e96b05b5503610e25ccda271 (patch)
tree6d395fd15cc0e13f83d74aa82b6959a5b4647808 /textproc/p5-Text-Similarity/Makefile
parent9cc8e73a2808d9ff193e41a60dc63c57c9bbeb5a (diff)
downloadports-c0a019ffac3154c3e96b05b5503610e25ccda271.tar.gz
ports-c0a019ffac3154c3e96b05b5503610e25ccda271.zip
Notes
Diffstat (limited to 'textproc/p5-Text-Similarity/Makefile')
-rw-r--r--textproc/p5-Text-Similarity/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/textproc/p5-Text-Similarity/Makefile b/textproc/p5-Text-Similarity/Makefile
new file mode 100644
index 000000000000..dac770bad201
--- /dev/null
+++ b/textproc/p5-Text-Similarity/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: Text::Similarity
+# Date created: Oct 28 2004
+# Whom: clsung
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-Similarity
+PORTVERSION= 0.02
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Perl module for measuring the similarity of text documents
+
+PERL_CONFIGURE= yes
+
+MAN1= text_compare.pl.1
+MAN3= Text::OverlapFinder.3 \
+ Text::Similarity.3 \
+ Text::Similarity::Overlaps.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>