aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Text-SpellChecker-GUI
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-09-30 14:21:44 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-09-30 14:21:44 +0000
commit7c86755dbb4f79bc22c5098a531062ee0d8a8e84 (patch)
treec83595565fe27f440ab619f83724e500a43f5ab1 /textproc/p5-Text-SpellChecker-GUI
parente4bc095dd6cb3acd219843260c2c27d8a4b744d7 (diff)
downloadports-7c86755dbb4f79bc22c5098a531062ee0d8a8e84.tar.gz
ports-7c86755dbb4f79bc22c5098a531062ee0d8a8e84.zip
Notes
Diffstat (limited to 'textproc/p5-Text-SpellChecker-GUI')
-rw-r--r--textproc/p5-Text-SpellChecker-GUI/Makefile28
-rw-r--r--textproc/p5-Text-SpellChecker-GUI/distinfo3
-rw-r--r--textproc/p5-Text-SpellChecker-GUI/pkg-descr6
-rw-r--r--textproc/p5-Text-SpellChecker-GUI/pkg-plist11
4 files changed, 48 insertions, 0 deletions
diff --git a/textproc/p5-Text-SpellChecker-GUI/Makefile b/textproc/p5-Text-SpellChecker-GUI/Makefile
new file mode 100644
index 000000000000..ade71dcdce86
--- /dev/null
+++ b/textproc/p5-Text-SpellChecker-GUI/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Text-SpellChecker-GUI
+# Date created: 2009-09-27
+# Whom: Zane C, Bowers <vvelox@vvelox.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-SpellChecker-GUI
+PORTVERSION= 0.0.1
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/V/VV/VVELOX
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vvelox@vvelox.net
+COMMENT= Implements a user interface to Text::SpellChecker using ZConf::GUI
+
+BUILD_DEPENDS= ${SITE_PERL}/Curses/UI.pm:${PORTSDIR}/devel/p5-Curses-UI \
+ ${SITE_PERL}/String/ShellQuote.pm:${PORTSDIR}/textproc/p5-String-ShellQuote \
+ ${SITE_PERL}/ZConf/GUI.pm:${PORTSDIR}/devel/p5-ZConf-GUI \
+ ${SITE_PERL}/Text/SpellChecker.pm:${PORTSDIR}/textproc/p5-Text-SpellChecker
+
+PERL_CONFIGURE= yes
+
+MAN3= Text::SpellChecker::GUI.3 \
+ Text::SpellChecker::GUI::Curses.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Text-SpellChecker-GUI/distinfo b/textproc/p5-Text-SpellChecker-GUI/distinfo
new file mode 100644
index 000000000000..1a5be409ce29
--- /dev/null
+++ b/textproc/p5-Text-SpellChecker-GUI/distinfo
@@ -0,0 +1,3 @@
+MD5 (Text-SpellChecker-GUI-0.0.1.tar.gz) = 129bdaf88948835d768c78f52a07918e
+SHA256 (Text-SpellChecker-GUI-0.0.1.tar.gz) = 0a2cdb32e0347158f337c61e8274fdbe8ba91edae2953b4ad3e594e1daed7ae4
+SIZE (Text-SpellChecker-GUI-0.0.1.tar.gz) = 7968
diff --git a/textproc/p5-Text-SpellChecker-GUI/pkg-descr b/textproc/p5-Text-SpellChecker-GUI/pkg-descr
new file mode 100644
index 000000000000..578e4324b620
--- /dev/null
+++ b/textproc/p5-Text-SpellChecker-GUI/pkg-descr
@@ -0,0 +1,6 @@
+This implements a spell checker to Text::SpellChecker
+using ZConf::GUI.
+
+textspellchecker - Spell checker script.
+
+WWW: http://search.cpan.org/dist/Text-SpellChecker-GUI
diff --git a/textproc/p5-Text-SpellChecker-GUI/pkg-plist b/textproc/p5-Text-SpellChecker-GUI/pkg-plist
new file mode 100644
index 000000000000..f723b97a8ae5
--- /dev/null
+++ b/textproc/p5-Text-SpellChecker-GUI/pkg-plist
@@ -0,0 +1,11 @@
+bin/textspellchecker
+bin/curses-textspellchecker
+%%SITE_PERL%%/Text/SpellChecker/GUI.pm
+%%SITE_PERL%%/Text/SpellChecker/GUI/Curses.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/SpellChecker/GUI/.packlist
+@dirrmtry %%SITE_PERL%%/Text/SpellChecker/GUI
+@dirrmtry %%SITE_PERL%%/Text/SpellChecker/
+@dirrmtry %%SITE_PERL%%/Text/
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/SpellChecker/GUI
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/SpellChecker
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text