aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Text-Unaccent
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-03-16 02:47:11 +0000
committerSteve Wills <swills@FreeBSD.org>2012-03-16 02:47:11 +0000
commitb1fca84506f184361afc5da277e2dfe04402a2d4 (patch)
treeec59e2b7adbaa813d0e63dd49b60a7326dc2f4a6 /textproc/p5-Text-Unaccent
parent4a44abaad9e566d3de70ded96f238dd80fd3d9f1 (diff)
downloadports-b1fca84506f184361afc5da277e2dfe04402a2d4.tar.gz
ports-b1fca84506f184361afc5da277e2dfe04402a2d4.zip
- Patches to fix tests
- Bump PORTREVISION Submitted by: rflynn@acsalaska.net (via irc) Feature safe: yes
Notes
Notes: svn path=/head/; revision=293391
Diffstat (limited to 'textproc/p5-Text-Unaccent')
-rw-r--r--textproc/p5-Text-Unaccent/Makefile2
-rw-r--r--textproc/p5-Text-Unaccent/files/patch-Unaccent.xs11
-rw-r--r--textproc/p5-Text-Unaccent/files/patch-unac.c15
3 files changed, 28 insertions, 0 deletions
diff --git a/textproc/p5-Text-Unaccent/Makefile b/textproc/p5-Text-Unaccent/Makefile
index f9bd3ce96b5d..75450eebb665 100644
--- a/textproc/p5-Text-Unaccent/Makefile
+++ b/textproc/p5-Text-Unaccent/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Text-Unaccent
PORTVERSION= 1.08
+PORTREVISION= 1
CATEGORIES= textproc perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -18,5 +19,6 @@ MAN3= Text::Unaccent.3
USE_ICONV= yes
PERL_CONFIGURE= yes
+CFLAGS+= -DICONV_CONST=const
.include <bsd.port.mk>
diff --git a/textproc/p5-Text-Unaccent/files/patch-Unaccent.xs b/textproc/p5-Text-Unaccent/files/patch-Unaccent.xs
new file mode 100644
index 000000000000..38aeb4c0fce7
--- /dev/null
+++ b/textproc/p5-Text-Unaccent/files/patch-Unaccent.xs
@@ -0,0 +1,11 @@
+--- Unaccent.xs.orig 2004-12-29 02:45:18.000000000 -0900
++++ Unaccent.xs 2012-03-15 17:04:26.000000000 -0800
+@@ -35,7 +35,7 @@
+ #include "unac.h"
+
+ static char* buffer;
+-static int buffer_length;
++static size_t buffer_length;
+
+ static void unac_debug_print(const char* message, void* data)
+ {
diff --git a/textproc/p5-Text-Unaccent/files/patch-unac.c b/textproc/p5-Text-Unaccent/files/patch-unac.c
new file mode 100644
index 000000000000..67cceacea899
--- /dev/null
+++ b/textproc/p5-Text-Unaccent/files/patch-unac.c
@@ -0,0 +1,15 @@
+--- unac.c.orig 2004-10-17 11:00:36.000000000 -0800
++++ unac.c 2012-03-15 16:55:01.042386000 -0800
+@@ -13881,10 +13881,10 @@
+ *out_lengthp = 0;
+ } else {
+ char* utf16 = 0;
+- int utf16_length = 0;
+ char* utf16_unaccented = 0;
+- int utf16_unaccented_length = 0;
++ size_t utf16_length, utf16_unaccented_length;
+
++ utf16_length = utf16_unaccented_length = 0;
+ if(convert(charset, utf16be(), in, in_length, &utf16, &utf16_length) < 0) {
+ return -1;
+ }