aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-WDDX
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2001-10-02 11:31:56 +0000
committerAnton Berezin <tobez@FreeBSD.org>2001-10-02 11:31:56 +0000
commit4e11187a6dd7f8157972f6dee80600a7bada8cf8 (patch)
treea2da312f0a0146d7ab6e048ab8f010aa6b41cb5b /textproc/p5-WDDX
parent7989932dd5f3efbd97e7d948f868d6c44ad7912a (diff)
downloadports-4e11187a6dd7f8157972f6dee80600a7bada8cf8.tar.gz
ports-4e11187a6dd7f8157972f6dee80600a7bada8cf8.zip
Add p5-WDDX 1.01, perl module to parse WDDX Packets.
PR: 30651 Submitted by: Eric A. Griff <eric@talesfromthereal.com>
Notes
Notes: svn path=/head/; revision=48338
Diffstat (limited to 'textproc/p5-WDDX')
-rw-r--r--textproc/p5-WDDX/Makefile31
-rw-r--r--textproc/p5-WDDX/distinfo1
-rw-r--r--textproc/p5-WDDX/pkg-comment1
-rw-r--r--textproc/p5-WDDX/pkg-descr14
-rw-r--r--textproc/p5-WDDX/pkg-plist16
5 files changed, 63 insertions, 0 deletions
diff --git a/textproc/p5-WDDX/Makefile b/textproc/p5-WDDX/Makefile
new file mode 100644
index 000000000000..cf8f5ace1e54
--- /dev/null
+++ b/textproc/p5-WDDX/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-WDDX
+# Date created: 18 September 2001
+# Whom: Eric A. Griff <eric@talesfromthereal.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WDDX
+PORTVERSION= 1.01
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/G/GU/GUELICH
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= eric@talesfromthereal.com
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+
+PERL_CONFIGURE= yes
+ALL_TARGET= all test
+MAN3= WDDX.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/WDDX
+ ${INSTALL_MAN} ${WRKSRC}/Changes ${PREFIX}/share/doc/WDDX
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-WDDX/distinfo b/textproc/p5-WDDX/distinfo
new file mode 100644
index 000000000000..87ab98dae47e
--- /dev/null
+++ b/textproc/p5-WDDX/distinfo
@@ -0,0 +1 @@
+MD5 (WDDX-1.01.tar.gz) = 67f147d9ce9855a98f1d5dd78f5335d2
diff --git a/textproc/p5-WDDX/pkg-comment b/textproc/p5-WDDX/pkg-comment
new file mode 100644
index 000000000000..76ec8b671180
--- /dev/null
+++ b/textproc/p5-WDDX/pkg-comment
@@ -0,0 +1 @@
+Perl module to parse WDDX Packets
diff --git a/textproc/p5-WDDX/pkg-descr b/textproc/p5-WDDX/pkg-descr
new file mode 100644
index 000000000000..57279be30256
--- /dev/null
+++ b/textproc/p5-WDDX/pkg-descr
@@ -0,0 +1,14 @@
+This is a module that parses WDDX packets. Which are
+well supported in Allaire Coldfusion, and pretty
+useful.
+
+This is from the WDDX.org web site: "The Web Distributed
+Data Exchange, or WDDX, is a free, open XML-based
+technology that allows Web applications created with any
+platform to easily exchange data with one another over the
+Web."
+
+For more information about WDDX, visit
+http://www.wddx.org/. For information about using Perl
+with WDDX (including examples) you can also visit
+WWW: http://www.scripted.com/wddx/.
diff --git a/textproc/p5-WDDX/pkg-plist b/textproc/p5-WDDX/pkg-plist
new file mode 100644
index 000000000000..f030dd7d9e32
--- /dev/null
+++ b/textproc/p5-WDDX/pkg-plist
@@ -0,0 +1,16 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/WDDX/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/WDDX.pm
+lib/perl5/site_perl/%%PERL_VER%%/WDDX/Array.pm
+lib/perl5/site_perl/%%PERL_VER%%/WDDX/Binary.pm
+lib/perl5/site_perl/%%PERL_VER%%/WDDX/Boolean.pm
+lib/perl5/site_perl/%%PERL_VER%%/WDDX/Datetime.pm
+lib/perl5/site_perl/%%PERL_VER%%/WDDX/Null.pm
+lib/perl5/site_perl/%%PERL_VER%%/WDDX/Number.pm
+lib/perl5/site_perl/%%PERL_VER%%/WDDX/Parser.pm
+lib/perl5/site_perl/%%PERL_VER%%/WDDX/Recordset.pm
+lib/perl5/site_perl/%%PERL_VER%%/WDDX/String.pm
+lib/perl5/site_perl/%%PERL_VER%%/WDDX/Struct.pm
+%%PORTDOCS%%share/doc/WDDX/Changes
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/WDDX
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/WDDX
+%%PORTDOCS%%@dirrm share/doc/WDDX