aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-WordNet-Similarity
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2003-07-08 01:16:27 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2003-07-08 01:16:27 +0000
commit17c93d66db577f067e279036cebee6906bf633e3 (patch)
tree0aaee3a9a3942b89a0f2316302d21b3d16c93d50 /textproc/p5-WordNet-Similarity
parent59d73865b219ae5447c995cb4c2c7fbf73a6d476 (diff)
downloadports-17c93d66db577f067e279036cebee6906bf633e3.tar.gz
ports-17c93d66db577f067e279036cebee6906bf633e3.zip
Notes
Diffstat (limited to 'textproc/p5-WordNet-Similarity')
-rw-r--r--textproc/p5-WordNet-Similarity/Makefile39
-rw-r--r--textproc/p5-WordNet-Similarity/distinfo1
-rw-r--r--textproc/p5-WordNet-Similarity/pkg-descr27
-rw-r--r--textproc/p5-WordNet-Similarity/pkg-plist30
4 files changed, 97 insertions, 0 deletions
diff --git a/textproc/p5-WordNet-Similarity/Makefile b/textproc/p5-WordNet-Similarity/Makefile
new file mode 100644
index 000000000000..5871394389d4
--- /dev/null
+++ b/textproc/p5-WordNet-Similarity/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: p5-WordNet-Similarity
+# Date created: 07 July 2003
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WordNet-Similarity
+PORTVERSION= 0.05
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WordNet
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Modules and a CLI to determine semantic relatedness using the WordNet database
+
+BUILD_DEPENDS= ${SITE_PERL}/WordNet/QueryData.pm:${PORTSDIR}/textproc/p5-WordNet-QueryData
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+WNHOME?= ${LOCALBASE}/share/WordNet-1.7.1
+
+PERL_CONFIGURE= yes
+CONFIGURE_ENV= WNHOME=${WNHOME}
+USE_REINPLACE= yes
+
+MAN3= WordNet::Similarity.3 WordNet::Similarity::jcn.3 \
+ WordNet::Similarity::hso.3 WordNet::Similarity::vector.3 \
+ WordNet::Similarity::random.3 WordNet::Similarity::res.3 \
+ WordNet::Similarity::lesk.3 WordNet::Similarity::edge.3 \
+ WordNet::Similarity::lin.3 WordNet::Similarity::lch.3
+post-patch:
+ @${REINPLACE_CMD} -e \
+ '/wnUnixPath/s|/usr/local/WordNet-1.7.1|${WNHOME}|; \
+ /wnUnixPath/s|."/dict"||' ${WRKSRC}/Makefile.PL
+ @${FIND} ${WRKSRC}/utils -type f| ${XARGS} ${REINPLACE_CMD} -e \
+ 's|/usr/local/bin/perl|${PERL}|'
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-WordNet-Similarity/distinfo b/textproc/p5-WordNet-Similarity/distinfo
new file mode 100644
index 000000000000..781e352920f6
--- /dev/null
+++ b/textproc/p5-WordNet-Similarity/distinfo
@@ -0,0 +1 @@
+MD5 (WordNet-Similarity-0.05.tar.gz) = dc82c6c971a480f3a082f6d9f1233d4a
diff --git a/textproc/p5-WordNet-Similarity/pkg-descr b/textproc/p5-WordNet-Similarity/pkg-descr
new file mode 100644
index 000000000000..f58ec498b7c7
--- /dev/null
+++ b/textproc/p5-WordNet-Similarity/pkg-descr
@@ -0,0 +1,27 @@
+From the README:
+
+This package consists of Perl modules along with supporting Perl programs that
+implement the semantic relatedness measures described by Leacock Chodorow
+(1998), Jiang Conrath (1997), Resnik (1995), Lin (1998), Hirst St Onge (1998)
+and the adapted gloss overlap measure by Banerjee and Pedersen (2002). The Perl
+modules are designed as object classes with methods that take as input two word
+senses. The semantic relatedness of these word senses is returned by these
+methods. A quantitative measure of the degree to which two word senses are
+related has wide ranging applications in numerous areas, such as word sense
+disambiguation, information retrieval, etc. For example, in order to determine
+which sense of a given word is being used in a particular context, the sense
+having the highest relatedness with its context word senses is most likely to
+be the sense being used. Similarly, in information retrieval, retrieving
+documents containing highly related concepts are more likely to have higher
+precision and recall values.
+
+A command line interface to these modules is also present in the package. The
+simple, user-friendly interface returns the relatedness measure of two given
+words. A number of switches and options have been provided to modify the output
+and enhance it with trace information and other useful output. Details of the
+usage are provided in other sections of this README. Supporting utilities for
+generating information content files from various corpora are also available in
+the package. The information content files are required by three of the
+measures for computing the relatedness of concepts.
+
+WWW: http://search.cpan.org/dist/WordNet-Similarity/
diff --git a/textproc/p5-WordNet-Similarity/pkg-plist b/textproc/p5-WordNet-Similarity/pkg-plist
new file mode 100644
index 000000000000..75e38e32d7a0
--- /dev/null
+++ b/textproc/p5-WordNet-Similarity/pkg-plist
@@ -0,0 +1,30 @@
+bin/semCor17Freq.pl
+bin/brownFreq.pl
+bin/rawtextFreq.pl
+bin/BNCFreq.pl
+bin/semTagFreq.pl
+bin/similarity.pl
+bin/wordVectors.pl
+bin/treebankFreq.pl
+bin/compounds.pl
+%%SITE_PERL%%/dbInterface.pm
+%%SITE_PERL%%/get_wn_info.pm
+%%SITE_PERL%%/stem.pm
+%%SITE_PERL%%/string_compare.pm
+%%SITE_PERL%%/WordNet/Similarity.pm
+%%SITE_PERL%%/WordNet/infocontent.dat
+%%SITE_PERL%%/WordNet/relation.dat
+%%SITE_PERL%%/WordNet/Similarity/edge.pm
+%%SITE_PERL%%/WordNet/Similarity/hso.pm
+%%SITE_PERL%%/WordNet/Similarity/random.pm
+%%SITE_PERL%%/WordNet/Similarity/lesk.pm
+%%SITE_PERL%%/WordNet/Similarity/lin.pm
+%%SITE_PERL%%/WordNet/Similarity/jcn.pm
+%%SITE_PERL%%/WordNet/Similarity/lch.pm
+%%SITE_PERL%%/WordNet/Similarity/res.pm
+%%SITE_PERL%%/WordNet/Similarity/vector.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WordNet/Similarity/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/WordNet/Similarity 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/WordNet 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/WordNet/Similarity 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/WordNet 2>/dev/null || true