aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-XML-DBMS
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2002-06-09 14:29:26 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2002-06-09 14:29:26 +0000
commit2aad458bb54c17bc8a4c0d34b467f29b95e5c825 (patch)
treebc8439ac3898aa1d2640bd1d778db15b3ed99a03 /textproc/p5-XML-DBMS
parent07f7bc041c995988b7a3abcc147c8b8ce0c2c983 (diff)
downloadports-2aad458bb54c17bc8a4c0d34b467f29b95e5c825.tar.gz
ports-2aad458bb54c17bc8a4c0d34b467f29b95e5c825.zip
Add p5-XML-DBMS 1.03, perl port of Java package XML-DBMS v1.0.
PR: 32970 Submitted by: Sergey Skvortsov <skv@protey.ru>
Notes
Notes: svn path=/head/; revision=60968
Diffstat (limited to 'textproc/p5-XML-DBMS')
-rw-r--r--textproc/p5-XML-DBMS/Makefile38
-rw-r--r--textproc/p5-XML-DBMS/distinfo1
-rw-r--r--textproc/p5-XML-DBMS/pkg-comment1
-rw-r--r--textproc/p5-XML-DBMS/pkg-descr12
-rw-r--r--textproc/p5-XML-DBMS/pkg-plist12
5 files changed, 64 insertions, 0 deletions
diff --git a/textproc/p5-XML-DBMS/Makefile b/textproc/p5-XML-DBMS/Makefile
new file mode 100644
index 000000000000..fb6df49d6061
--- /dev/null
+++ b/textproc/p5-XML-DBMS/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: XML::DBMS
+# Date created: 18 Dec 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML-DBMS
+PORTVERSION= 1.03
+CATEGORIES= textproc databases perl5
+MASTER_SITES= ftp://ftp.rpbourret.com/
+PKGNAMEPREFIX= p5-
+DISTNAME= perl-xml-dbms-1.03
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= skv@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/XML/Parser/PerlSAX.pm:${PORTSDIR}/textproc/p5-libxml \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PLIST_SUB= EXAMPLESDIR="share/examples/${PORTNAME}"
+WRKSRC= ${WRKDIR}/${PORTNAME}
+PERL_CONFIGURE= yes
+
+post-extract:
+ @${FIND} ${WRKSRC} -type f | \
+ xargs ${PERL} -pi -e 's/\x0D(?=\x0A)//g'
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/samples/*.* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-XML-DBMS/distinfo b/textproc/p5-XML-DBMS/distinfo
new file mode 100644
index 000000000000..6eefd7d0c6ea
--- /dev/null
+++ b/textproc/p5-XML-DBMS/distinfo
@@ -0,0 +1 @@
+MD5 (perl-xml-dbms-1.03.tgz) = f10dbd7c4f91f6437c45139d15c2fc3a
diff --git a/textproc/p5-XML-DBMS/pkg-comment b/textproc/p5-XML-DBMS/pkg-comment
new file mode 100644
index 000000000000..ba62867cfe70
--- /dev/null
+++ b/textproc/p5-XML-DBMS/pkg-comment
@@ -0,0 +1 @@
+Perl port of Java package XML-DBMS v1.0
diff --git a/textproc/p5-XML-DBMS/pkg-descr b/textproc/p5-XML-DBMS/pkg-descr
new file mode 100644
index 000000000000..4296a1f0aeaf
--- /dev/null
+++ b/textproc/p5-XML-DBMS/pkg-descr
@@ -0,0 +1,12 @@
+XML-DBMS is middleware for transferring data between XML documents and
+relational databases. It views the XML document as a tree of
+data-specific objects in which element types are generally viewed as
+classes and attributes and PCDATA as properties of those classes. It
+then uses an object-relational mapping to map these objects to the
+database. An XML-based mapping language is used to define the view and
+map it to the database.
+
+WWW: http://www.rpbourret.com/xmldbms/index.htm
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/textproc/p5-XML-DBMS/pkg-plist b/textproc/p5-XML-DBMS/pkg-plist
new file mode 100644
index 000000000000..ec14ed1add84
--- /dev/null
+++ b/textproc/p5-XML-DBMS/pkg-plist
@@ -0,0 +1,12 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/XMLtoDBMS/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/XML/XMLtoDBMS.pm
+%%PORTDOCS%%%%EXAMPLESDIR%%/sales.map
+%%PORTDOCS%%%%EXAMPLESDIR%%/sales.pl
+%%PORTDOCS%%%%EXAMPLESDIR%%/sales.sql
+%%PORTDOCS%%%%EXAMPLESDIR%%/sales.xml
+%%PORTDOCS%%%%EXAMPLESDIR%%/sales1.map
+%%PORTDOCS%%%%EXAMPLESDIR%%/sales2.map
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML/XMLtoDBMS
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/XML 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/XML 2>/dev/null || true